Options for Lovelace on older iPad (ios 9.3.5)

Hi, I have in exactly the same situation, same RPi3b+ and iOs on iPad2. Running the container with “docker run -it jlesage/firefox” returns the error:

standard_init_linux.go:211: exec user process caused “exec format error”
failed to resize tty, using default size

Any idea what can happen?


1 Like

Usually this error happens with wrong architecture of the image. Check if the image supports your cpu architecture and use appropriate tag.

Nice find @kumar ! This was my first foray into Docker and I was pleasantly surprised when it worked without any issues (using Docker Desktop on WSL2, which recently became available for Windows 10 Home edition). I now use an iPad1 (ios 5.1.1) as well as an iPad2 as HA dashboards!


@squirtbrnr is that the way you have it running on your end? Could you possibly provide a step by step guide? It would be great if somebody detailed how to run this on HA (former hassio)

1 Like

There’s no point in me making a guide because the dockerhub page for the image already contains the instructions on how to set up the docker container. There’s no configuration to be done in HA.

Well, the guide I was referring to was mainly for HA. I don’t have another box laying around that I can run the Docker in, that’s why I want to run this brilliant idea in the same box where HA is running in.

I know enough about HA Supervised to know that the supervisor is running docker to manage all of the add-ons but that’s all I know. So if there’s a way to SSH into the supervisor, then you can setup and run this image in a container using the image supplied docker run commands. You could possibly even use the Portainer add-on, but I know even less about Portainer because all of my docker container management happens via SSH on my Synology NAS. My point is, running this Firefox docker image is HA agnostic or indifferent, and even host indifferent (within the limits of the hardware the image supports). It sounds like you’d be better served by someone creating an add-on in HA for this. Which is something I know absolutely nothing about.

1 Like

thanks @squirtbrnr

I realize I did not acknowledge your response. An add-on would definitely be helpful. I too feel I’m not skilled to even consider doing this :frowning:

I will try to suggest it in Github (no idea how I should do that but I will investigate). Thanks again.

Yup. Firefox container works for desktop architecture amd64. Not available yet for arm devices.
Docker firefox in desktop with ipad mini 1 and VNC:

1 Like

I’m also seeing this error on RPi3b+. Any idea what the issue is? Do I need to use a different image? I didn’t see any other images for different architectures

Do you know if a version for arm is being worked on? How can I be alerted if that ever becomes available?

Nope, that will depend of the developer who’s making the firefox container. I’ve found that someone already asked about ARM support and some cases in issues section about working container on a rpi4.

Hello @kumar.
Thank you for these useful link
Unfortunately I don’t succeed to start Firefox after installing Firefox on docker (with quick install : docker run - d - - name=Firefox…) in portainer. I receive a error message standard_init_linux.go:211: exec user process caused "exec format error
Unfortunately I am beginner on docker, and that is maybe because I forget to do something important. Does someone help me to solve this issue please?

The iOS app here: https://apps.apple.com/us/app/home-assistant/id1099568401?ls=1

Seems to work with the 0.117 release here:

Did not try it :wink:

Thank you @Romkabouter​:wink: unfortunately I have tried this link but the answer is that HA is not compatible with my iPad even if it is IOS 9.3.5) :sob::thinking:

Did you try the app or safari? Are you on version 0.117?
After reading, I think the app is still not for older iPads, but safari might be useable.

I have some issues with 0.117, but will try as well when I have fixed them

In fact I realize that the app is not compatible but we can now load HA via our http://192.168.1.xx:8123 without issue.
But the problem that this 117 release does not support yet some ccs codes included in the majority of my lovelace :cry:

Ah, that is a pity. But being able to login is a nice step :slight_smile:

Working on iPad 2, but only standard cards, no custom ones.

1 Like

i installed home assistant via this image:

as i understand, i don’t run Home Assistant in a docker, so i have no easy option to access the root OS (which is Hassio?)

do i have any option to install firefox as a docker so i can access it via an old ipad3?
maybe someone can help me because im a little bit lost here, and i don’t want to redo everything again to install first raspian or any other os and on top the home assistant.

thx and best regards @all