Options for Sunpower solar integration?

yup, i can confirm now (thanks for the suggestion), that plugging in the OTG Micro USB adapter directly into a switch on the network grabs a direct IP address on the network

so now the question might be is the ethernet → USBA working? or maybe there’s a good way to interrogate the connection. not sure if dhcp works on the PVS or the IP address should be hardcoded somehow on the 172.x network

If you’re following the usual PVS setup guide for use with HA, you’d be using a DHCP client to talk to the PVS and it will give you an address (and as I noted earlier today, in the recent firmware will also give you a default gateway, causing all kinds of trouble).

Do you have a laptop you can plug into the Ethernet+PVS connection see if it is able to get an address from the PVS?

several laptops but have to pick up an adapter since i only have USB-C outputs on this thing.

tried with a regular Pi 4 and it booted, still gave the 169.x even with just the spec’d adapter that Sunpower provides in their docs, so will retry with a laptop when Amazon drops it later today

Odd, plugged in with the Pi Zero W and still getting the 169.x and running dhclient against eth0 is giving

sudo dhclient eth0 -v
Internet Systems Consortium DHCP Client 4.4.1
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/c8:4d:44:28:08:18
Sending on   LPF/eth0/c8:4d:44:28:08:18
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 7
DHCPDISCOVER on eth0 to port 67 interval 21
DHCPDISCOVER on eth0 to port 67 interval 17
DHCPDISCOVER on eth0 to port 67 interval 9
DHCPDISCOVER on eth0 to port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

plugged in a laptop to the USB → ethernet cable and still got the self-assigned IP so i’m going to try the other cable variant next.

looks like it was just a bad usb dongle from plugable, or not supported. the cable matters one worked flawlessly. and i’ve got data, w00t! thank you @kpfleming for the help

1 Like

There is now another option for SunPower integration into Home Assistant, using ESPHome as the bridge between them. If you’re an ESPHome user already, or just curious, take a look here.

Do you have any details as to how it does not void the warranty? I ask because every few month the sunpower app and website show disconnected from my PVS6 although HA is still gathering data and showing it working.
The last time this happened it was like a month to get it all going again with Sunpower tech support. They told me they they didn’t like me connecting and monitoring myself and if the problem happened again they would not help.
By chance do others ever experience the app loosing communications to the PVS6 while HA continues to communicate and gather data?
I am using the iNet router, LAN → Ethernet → iNet → Ethernet → PVS6.
It has been running ok for 9 months with the this occasional hiccup. PVS6 is also wired to my LAN instead of wifi for its regular internet connection.

Yes, this has happened to me at least two times. The first time was spring of this year, installer tech came out and reported that the PVS had failed to upgrade itself when the most recent software upgrade was downloaded. He forcibly upgraded it, and then it was fine.

The second time was a couple of months ago, but since I was still getting data into HA I didn’t care. About 5 weeks after the problem started it cleared itself. I failed to check to see if there was a software version upgrade this time as well.

When the tech was out here the first time he noted that since AT&T cellular service is really terrible at our house (we don’t use it, but the PVS does) that could explain some of this, as the PVS will use the cellular service for some activities even when it has a LAN or WiFi connection to the Internet. That didn’t make any sense to me, but I wouldn’t be surprised if it’s true.

Thanks! I’ll try tech support again and see if it’s and easy fix this time. I wouldn’t care too much either since HA is reporting but my generation has been low recently and just want to double check the app.

Any word on external monitoring and the warranty not being voided? Does it specifically say you can use 3rd party monitoring? or is it that we are just DL’ing the json file which is allowed? Is it clear in their warranty?

I see this

The Limited Warranty does not apply to any of the following:
a) improper or unauthorized installation, alteration, modification or repair made to the equipment or associated wiring and parts by
someone other than an authorized technician of SunPower;
b) the equipment was damaged by external forces such as power line disturbances, host computer malfunction, incorrect cabling or
plugging the board in under power;
c) damage, malfunction, or degradation of electrical output caused by failure to properly operate or maintain the equipment;
d) accidental breakage or damage, malfunction, or degradation of electrical output resulting from homeowner or third-party misuse,
abuse, accident, alteration, improper use, negligence, or vandalism;
e) product part identification labels which are missing or illegible;
f) damage from persons, pests, animals, biological activity, environmental pollution or industrial chemical exposure;
g) the components in the construction base on which the equipment is mounted are defective;
h) Force Majeure events, including without limit, any act or event which is unforeseeable, or being foreseeable, unavoidable and outside
the control of SunPower, including, without limitation, power failure surges, lightning, flood, fire, environmental or atmospheric
disturbance; and
i) Ordinary wear and tear or cosmetic imperfections, such as discoloration, fading, or weathering.
This warranty does not apply to expendable items such as fuses, light bulbs, and batteries. This warranty also does not apply to the software
used in connection with the PVS.

I had this working with a raspberry pi zero until my sd card crapped out. I ended up running an ethernet cable to the pvs6 and tried the intermediate router config. But no luck. I recently tried again to get this working and even if I connect directly to my laptop the pvs6 DHCP server doesn’t seem to work and I can’t access the url at all.

Anybody dealt with this?

I have a PVS6 system (which has all of the ethernet ports) installed a few months ago. I just followed the steps in the PDF guide and installed an RPi Zero 2 W that’s assigned a static IP of Interestingly, when I go to, everything is working and I see all my devices. However, when I try going to or, I get a 403 Forbidden error.

I thought this may have been an error with how I setup HA proxy, so I tried connecting my laptop to the PVS6 WiFi, however I see the same 403 Forbidden page when navigating to http://sunpowerconsole.com/, http://www.sunpowerconsole.com/, and I also verified that is the correct IP address for the unit and power cycled the PVS6 unit by flipping the breaker that connects to it. Anyone experiencing a similar issue and/or have any ideas of what may be going on here?

I have the same “issue”. My PVS6 stopped reporting to the cloud over the summer however the API never stopped working so HA had all the data and I knew the system was working. The installer came out and fixed the issue, I assume with a software update as I tried everything imaginable on my end. That’s when I noticed the console page stopped loading.

The issue came back a month later and I never bothered to report it this time, the installer still insisted on coming out to fix the issue, again I assume a software update took place and the console page is still 403.

I don’t think it much matters as long as HA can pull the data, it’s not like there’s much you can do on that page. My guess is they don’t want non-installers having access to it at all.

I sort of figured my system stopped reporting due to me being connected to the service port and that possibly keeping the PVS6 from automatically applying software updates. I’m curious if anyone can speak to this?

I was trying to add the RPi to the integration last night but kept getting a “Cannot Connect” error so I assumed it was because of the 403 Forbidden page that I was seeing. However, this morning I just re-tried and it decided to work. Not sure what changed (other than the fact that my panels were started to produce power), but hopefully it’s all good now!

It’s so annoying that we have to jump through hoops and backdoors just to get this data working though. I hope they don’t push an update in the future and disable the API unless you’re using the Sunpower installer app or something.

I’ve wondered the same; my PVS6 is now on its third episode of ‘no cloud reporting’ and I’ve stopped caring. In my case I have an unusual home network with redundant routers and I’ve noticed that the reporting failures started after the routers switched roles, and assumed the IP stack in the PVS6 is just crap :slight_smile: Still, power-cycling it does not cure the problem.

In addition, the cellular backup system doesn’t work on my PVS6 because it’s on the AT&T network and there is nearly no coverage from that network at my house, which meant the last tech who came out had to spend a lot of extra time getting a software update applied.

Had the same problem in November 2
The cloud app was not working
I noticed my intergration was not get data. I restarted the pie and it started working. But the API still was not working. It was connected to my WiFi but not getting data.
I powered down the sunpower system to reset but still no go. it had one day it reported some data for a couple hours.

Called sunpower they said they can’t help and for me call the contractor. They came out first week of December did something and it’s working again but historical data is gone from API for the 6 weeks it was down
I lost some history on the intergration for the few days before I noticed it was not working.

I was not here when they came.
But Barbara said the tech said it was a software issue and database to large or something like that.

So is this from a update?
Or is the intergration and being connected to installer port causing issues during updates?

I’ve been looking at making an integration that just queries the sunpower website.

I’ve determined it logs in with okta, then makes queries with graphql. Unfortunately, I know neither, so it’s going to be a big learning curve.

And I’ve been sidetracked with other projects, too :weary:

1 Like

Personally, I would avoid grabbing data from the web. I have issues where the PVS6 is simply missing the data. Multiple times a day, sometimes in excess of 10m the power data is just gone. The Energy data is then incorrect and cannot be relied upon. They have told me database issues, replaced the pVS6, network, etc. I am dealing with executive escalations now. I paid to have my data and I want all of it, 99.9999%. I am holding them to the same standards that my customers hold me to. I certainly didn’t pay $38k for missing data.

1 Like

We aren’t really monitoring their device. We are grubbing the same data that their website offers. You are plugging an ethernet cable into an existing port, to pull data. You are displaying the same data in a different view. It is 100% YOUR data. You are not voiding the warranty.

I’ve been searching around and haven’t been able to find an answer to this. I have a Sunpower system with a PVS6; during installation I requested that they connect via a hard wire to my existing router vs wifi, which they did. So I have a hard line running from the PVS6 to the wifi router in my living room.

I can’t actually figure out how to open the damn box to take a look, so I’m not sure, but I assume that inside the PVS6 box they have a USB-ethernet adapter connected to the PVS6, and the ethernet cable plugged into that on their end.

So if I want to set up an integration, am I right in thinking I should set up a basic travel router in my living room, bridge it to my existing wifi router, and plug the PVS6 into that instead? Or is there a simpler way that I’m just not seeing – I am running an ASUS RT-AX86U router with Merlin installed, so maybe there’s some kind of software solution in the router itself I could use?

You’ll need a second compatible usb to ethernet dongle as well as an additional ethernet cable run to the pvs6 to use the travel router. Alternatively you could use the cable that is there now and connect that to the other USB port and connect the PVS6 to your network with wifi.

The api is only accessible on the service port, not the port usb to provide it access to the internet.

That’s how I have mine connected, two ethernet cables come into the house connected to 2 different dongles, one provides internet access through my router and the other goes to a spare router I use to bridge the network the PVS6 puts out and my own network.

You can open the PVS6 with a key or screw driver fairly easily. There’s a tab on the bottom you pry to pop the cover off. My installers had apparently never seen the version with USB ports before and tried connecting the ethernet cable directly to the built in ethernet ports. This did nothing and they eventually gave up and asked for my wifi password. If your installer ever asked for your wifi, chances are it’s already connected to your network via wifi. I don’t believe USB dongles are part of the install kit so I’d be surprised if they just happened to have one.