Options for Sunpower solar integration?

I use hass-sunpower but don’t use HACS; it’s fairly easy to install directly into the custom_components folder of the HA installation.

I’m still new to HA and didn’t realize hass-sunpower without HACS was an option - thank you. At this point I have data access, so I’m most interested in adding better visualizations (e.g. cards).

Hi all - I’m waiting for my Sunpower to be installed, hopefully sometime in May. Prepping my system it looks like the newer PVS6 won’t have the Ethernet port and there has been an excellent writeup on using a Pi, however I’d rather go with an IoT route. Is the Gl.inet travel router method still working with the new PVS6 with a compatible USB Ethernet adapter?

I can’t speak to the travel router, but I was able to use a supported USB to Ethernet adapter to an old Asus router which then connects to my unifi switch with the proper static routes per the guide.

I set this up by connecting the ethernet to my local network and WiFi to the PVS6 access point in my Raspberry PI.

FYI: My PVS6 recently got a firmware upgrade to “2023.3, Build 61410”.

Apparently the DHCP server in the PVS now indicates that it should be the ‘default gateway’ to my system that is using the API, which of course results in that system being broken since no other networks are actually reachable through the PVS. Once I realized this had changed I configured the DHCP client to ignore the ‘default gateway’ setting and my network went back to normal.

I’m at a bit of a loss, i thought i had bought the appropriate things. i have a newer PVS6 which has the USB dongle only for networking … i’ve plugged them into the right spots but i don’t think the adapters are right. I’ve got the USB → ethernet dongle (from docs) and then ethernet → mini-USB (or whatever the Pi Zero w takes)… i don’t know what i’ve done wrong but nothing is attached though eth0 does show up it’s always a 169.x.x.x

What is this item you are referring to? Can you provide a name/model number, or a link?

Definitely. it’s the OTG Micro USB Ethernet Adapter (bought from a link in the PDF)

Have you confirmed that the Pi Zero plus that adapter works on another Ethernet connection in your network? I think I’d want to do that before combining it with the PVS and adding so many more variables to the equation :slight_smile:

yup, i can confirm now (thanks for the suggestion), that plugging in the OTG Micro USB adapter directly into a switch on the network grabs a direct IP address on the network

so now the question might be is the ethernet → USBA working? or maybe there’s a good way to interrogate the connection. not sure if dhcp works on the PVS or the IP address should be hardcoded somehow on the 172.x network

If you’re following the usual PVS setup guide for use with HA, you’d be using a DHCP client to talk to the PVS and it will give you an address (and as I noted earlier today, in the recent firmware will also give you a default gateway, causing all kinds of trouble).

Do you have a laptop you can plug into the Ethernet+PVS connection see if it is able to get an address from the PVS?

several laptops but have to pick up an adapter since i only have USB-C outputs on this thing.

tried with a regular Pi 4 and it booted, still gave the 169.x even with just the spec’d adapter that Sunpower provides in their docs, so will retry with a laptop when Amazon drops it later today

Odd, plugged in with the Pi Zero W and still getting the 169.x and running dhclient against eth0 is giving

sudo dhclient eth0 -v
Internet Systems Consortium DHCP Client 4.4.1
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/c8:4d:44:28:08:18
Sending on   LPF/eth0/c8:4d:44:28:08:18
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 7
DHCPDISCOVER on eth0 to port 67 interval 21
DHCPDISCOVER on eth0 to port 67 interval 17
DHCPDISCOVER on eth0 to port 67 interval 9
DHCPDISCOVER on eth0 to port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

plugged in a laptop to the USB → ethernet cable and still got the self-assigned IP so i’m going to try the other cable variant next.

looks like it was just a bad usb dongle from plugable, or not supported. the cable matters one worked flawlessly. and i’ve got data, w00t! thank you @kpfleming for the help

1 Like

There is now another option for SunPower integration into Home Assistant, using ESPHome as the bridge between them. If you’re an ESPHome user already, or just curious, take a look here.

Do you have any details as to how it does not void the warranty? I ask because every few month the sunpower app and website show disconnected from my PVS6 although HA is still gathering data and showing it working.
The last time this happened it was like a month to get it all going again with Sunpower tech support. They told me they they didn’t like me connecting and monitoring myself and if the problem happened again they would not help.
By chance do others ever experience the app loosing communications to the PVS6 while HA continues to communicate and gather data?
I am using the iNet router, LAN → Ethernet → iNet → Ethernet → PVS6.
It has been running ok for 9 months with the this occasional hiccup. PVS6 is also wired to my LAN instead of wifi for its regular internet connection.

Yes, this has happened to me at least two times. The first time was spring of this year, installer tech came out and reported that the PVS had failed to upgrade itself when the most recent software upgrade was downloaded. He forcibly upgraded it, and then it was fine.

The second time was a couple of months ago, but since I was still getting data into HA I didn’t care. About 5 weeks after the problem started it cleared itself. I failed to check to see if there was a software version upgrade this time as well.

When the tech was out here the first time he noted that since AT&T cellular service is really terrible at our house (we don’t use it, but the PVS does) that could explain some of this, as the PVS will use the cellular service for some activities even when it has a LAN or WiFi connection to the Internet. That didn’t make any sense to me, but I wouldn’t be surprised if it’s true.

Thanks! I’ll try tech support again and see if it’s and easy fix this time. I wouldn’t care too much either since HA is reporting but my generation has been low recently and just want to double check the app.

Any word on external monitoring and the warranty not being voided? Does it specifically say you can use 3rd party monitoring? or is it that we are just DL’ing the json file which is allowed? Is it clear in their warranty?

I see this

The Limited Warranty does not apply to any of the following:
a) improper or unauthorized installation, alteration, modification or repair made to the equipment or associated wiring and parts by
someone other than an authorized technician of SunPower;
b) the equipment was damaged by external forces such as power line disturbances, host computer malfunction, incorrect cabling or
plugging the board in under power;
c) damage, malfunction, or degradation of electrical output caused by failure to properly operate or maintain the equipment;
d) accidental breakage or damage, malfunction, or degradation of electrical output resulting from homeowner or third-party misuse,
abuse, accident, alteration, improper use, negligence, or vandalism;
e) product part identification labels which are missing or illegible;
f) damage from persons, pests, animals, biological activity, environmental pollution or industrial chemical exposure;
g) the components in the construction base on which the equipment is mounted are defective;
h) Force Majeure events, including without limit, any act or event which is unforeseeable, or being foreseeable, unavoidable and outside
the control of SunPower, including, without limitation, power failure surges, lightning, flood, fire, environmental or atmospheric
disturbance; and
i) Ordinary wear and tear or cosmetic imperfections, such as discoloration, fading, or weathering.
This warranty does not apply to expendable items such as fuses, light bulbs, and batteries. This warranty also does not apply to the software
used in connection with the PVS.

I had this working with a raspberry pi zero until my sd card crapped out. I ended up running an ethernet cable to the pvs6 and tried the intermediate router config. But no luck. I recently tried again to get this working and even if I connect directly to my laptop the pvs6 DHCP server doesn’t seem to work and I can’t access the url at all.

Anybody dealt with this?