Orico ssd usb case boot problem pi3 and pi4 with 5.7 and up

Hi Guys,

I have 3 SSD usb cases.
2 Orico (different versions) and 1 Seagate.

After the 5.8 and 5.9 (I was running 5.2 I believe) update I’m unable to boot from the Orico cases (tried different cables and ssd’s). On Both the PI3 and Pi4!
The Seagate has no problem and boots fine.

Going back to OS 4.15 (on pi3) works fine on all USB SSD cases.

Anyone else have this problem?

#edit… just tried 5.2 on pi3 and it boots and works like a charm on the Orico devices.
Everything 5.7 and up doesnt work (haven’t tried 5.3/4/5/6). I tried 5.7, 5.8 and 5.9 both 32 and 64bit versions and all of them failed to boot on the Orico devices.


Had same problem
on pi4 i use 64bit version usb-ssd
With full restart i start my pi first and power my usb-ssd a few seconds later

I am having similar issue. Did you find a solution?

I tried to use HAOS 6.1 on a Pi3B+ that was running Raspberry Pi OS fine for years using an SSD. It would not boot apart from using 4.20.

I appear to have found a fix that I have posted here

You will need the 4.20 files I have stated but if you flash a spare SSD or maybe SD card you can get the files you need to copy over.