OS 3.13 to 4.8

Tags: #<Tag:0x00007f3285aa1d10> #<Tag:0x00007f3285aa19c8>

I have always payed attention to updates since December.
How is it I’m just now getting a OS update from 3.13 to 4.8?

Will I have any issues jumping that many updates?

Will this fix this error when appdaeman stsrts?

WARNING: You are using pip version 19.2.3, however version 20.1.1 is available.
You should consider upgrading via the pip install --upgrade pip' command.

If using HASIO how do I do this pip update?

It is one update.

1 Like

Oh I was looking at comparison and it looked like there was several before that just making sure I don’t have to update in progression.

4.8 is the first official 4.x release of the OS. The other 4.x releases were pre-releases.

This will not impact the message you posted from AppDaemon, which is not an error. In a nutshell, pip is a package installer for Python. The AppDaemon add-on is using a slightly older version of pip but this does not impact the function of the add-on in any way.

1 Like

I will not be home for another day I will try the update then because I have seen a few post of not being able to log in after

I just tried to update right now, and after one hour my instance is still not up…I restarted it several times (running a Raspberry Pi), but still it is broken…

I just tried it on a Raspberry Pi a few times. The system will not come back up to the web interface, when I plug the PI into an HDMI I can see it stalling at log on and asking for a user name and password

A couple of reboots and its come back up ok but still on 3.13

I just now did from 3.13 to 4.9 no issues so far

this morning I have this!
UPDATE AVAILABLE!
Operating System 3.13
You are currently running version 4.8

yo estoy igual que chirs669 que hacemos?

edito: ya salio 4.10 y ya actualice

I am running 0.110.5, tried to upgrade OS and got below error:
OSupgrade_error

Any idea about this error?
I also lost remote access after upgrade 0.109 to 0.110. Despite setting up external_url and internal_url, external access via duckdns stopped working. Not sure if both problems are connected.

I just we t from . 9 to.10no issues

Pie4 SD card

prueba a refrescar la web y luego intentas actualizar. a mi me pasa a menudo y solo es eso. espero haberte ayudado

inglese grazzi