Os-agent and systemd-resolved are missing at clean installation Supervised / Raspberry OS 64-bit

I am installing everything on a clean bootable SSD drive: The Raspberry OS 64-bit has been installed succesfully.

The following have been installed according to the procedure for Supervised:

I have installed the OS-agent 1.5.1:

wget https://github.com/home-assistant/os-agent/releases/download/1.5.1/os-agent_1.5.1_linux_armv7.deb
dpkg -i os-agent_1.5.1_linux_armv7.deb

Next, I have tried to install the systemd-resolved using the command:
apt install systemd-resolved
The error message is still same: E: Unable to locate package systemd-resolved

Finally, the Home Assistant installation is failed:

wget https://github.com/home-assistant/supervised-installer/releases/latest/download/homeassistant-supervised.deb
apt install ./homeassistant-supervised.deb

with error:

The following packages have unmet dependencies:
 homeassistant-supervised : Depends: os-agent but it is not installable
                            Depends: systemd-resolved but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I resolve two issues?

This is your problem.

From: architecture/adr/0014-home-assistant-supervised.md at master · home-assistant/architecture · GitHub

Supported Operating System, System dependencies and versions

Docker CE (Community Edition) is the only supported containerization method for Home Assistant Supervised. We only support FHS 3.0 on the host file system.

  • Docker CE >= 20.10.17
  • Systemd >= 239
  • NetworkManager >= 1.14.6
  • udisks2 >= 2.8
  • AppArmor == 2.13.x (built into the kernel)
  • Debian Linux Debian 12 aka Bookworm (no derivatives)
  • Home Assistant OS-Agent (Only the latest release is supported)

Only the above-listed version of Debian Linux is supported for running this installation method. When a new major version of Debian is released, the previous major version is dropped, with a deprecation time of 4 months. An exception to this rule occurs if the new version does not meet the requirements of the Supervisor.

1 Like

Debian 11 already has systemd-resolved.
install using:

sudo dpkg -i --ignore-depends=systemd-resolved ./homeassistant-supervised.deb

once it installs, edit /var/lib/dpkg/status and remove system-resolved from homeassistant-supervised Depends


Good !! Solved

Hello good sir, you flagged my post as inappropriate where I thanked e3palma and pointed out that your comment wasn’t helpful.

May I know what you find inappropriate about my comment? I checked the guidelines and disagreeing with lord NathanCu is neither defined as offensive nor abusive.

I did no such thing. I’m sorry they found it such but that wasn’t me.

Strange… In that case, I’m terribly sorry I assumed it was you. Have a good day Lord NathanCu :slight_smile:

it works!
i’d install HA with command
sudo BYPASS_OS_CHECK=true dpkg -i --ignore-depends=systemd-resolved ./homeassistant-supervised.deb