OS update automatic?

Once upon a time OS updates where available in the Update dialog within Settings.
Since about 6 to 8 months i see Core updates only. Which i run regularly. Why there are no more updates to the OS? Version 8.2 is not the latest version.

The reason i would like to update OS is Autobackup: When trying to configure i get message that i have to upgrade OS before i can use AutoBackup…!

Actual SW:

Home Assistant 2023.6.1
Supervisor 2023.06.2
Operating System 8.2

To upgrade manually is it sufficient to run CLI “ha os update” ???

Without more information, there is no way to know.

What type of installation do you have? (e.g HASSOS, supervised, etc)
What is the hardware? (e.g. RPi4, x86 PC, etc)

Current versions are Supervisor 2023.06.2 and Operating System 10.3.

Look in:

  • Settings → About
  • Settings → System → Hardware
  • Settings → System → Updates

Hi James
Thank you for responding.
HA is running on Raspberry Pi 4

All other infos i already mentioned in my first post.

I really do not know the type of installation: I installed a pre-configured system. I think it is HASSOS. This cannot be made visible?

cli comand “ha os info” reports:

board: rpi4-64
boot: A
data_disk: SD64G-.....
update_available: true
version: 8.2
version_latest: 8.5

Why is the latest OS version not installed automatically? Or on the list of pending updates?


First option:

  • Settings → System → Updates
  • Press the ‘check for Updates’ button top right
  • Press the ... top right, and ensure skip updates is not ticked
    Link to Updates – My Home Assistant

Second option:

  • Install the Terminal & SSH Add-On
  • Select Terminal from the web interface to get a HASS command line shell
  • Try: ha refresh-updates
  • Try: ha available-updates
  • Try: ha core update
  • Try: ha core info

PS Text formatted with code blocks is much easier to read and understand if you want to post error messages. Right-Shift-Click selects text and copies it from the web terminal.

If this helps, :heart: this post!

1 Like


some commands get error message:

BUT… in the meantime i run “ha os update”. That installed OS version 8.5, quietly. So far ok (but unusual).

The interesting part is that now the setting-update dialog contains the OS update 10.3 !! That surprises me, but ok… will update that also.,

Thanks for you support.

Interestingly, my HAOS 10.3 / HS Core 2023.6.2 install is also giving 403 errors - which might suggest an issue with Nabu Casa update servers at the moment.

[core-ssh ~]$ ha core update
Processing... Done.

Error: Version 2023.6.2 is already installed

[core-ssh ~]$ ha refresh-updates
ERRO[0000] Unexpected server response. Status code: 403 
Unexpected server response. Status code: 403

[core-ssh ~]$ ha available-updates
ERRO[0000] Unexpected server response. Status code: 403 
Unexpected server response. Status code: 403

[core-ssh ~]$ ha core info
arch: aarch64
audio_input: None
audio_output: None
boot: true
image: ghcr.io/home-assistant/yellow-homeassistant
machine: yellow
port: 8123
ssl: false
update_available: false
version: 2023.6.2
version_latest: 2023.6.2
watchdog: true

I’m going to update core and OS using the UI System-Update path. Hope it works… i assume the use the os command in the background…

did you disable the update enttity by accident?
System → devices &servyces → entities

you can show disabled entities if you can’t find it and enable it.

entities for OS and core are ON. For supervisor OFF.

Is that ok? and normal? I have not changed any of these entities.

ON means there is an update,
OFF means no update,
which makes sence,
however, no clue why you don’t see them in settings.
If you click on them you probably can hit install
not sure if anything has been fixed here since haos 8.x

Since i upgraded from 8.2 to 8.5 using “CLI os upgrade” which installed 8.5 i see the upgrade 10.3 in the update dialog. It’s currently upgrading… :grinning:

So the ON/OFF switches are not to control whether or not to upgrade but to inform if there are upgrade available.

Thanks for helping.