Out of the blue hardware issues with hassio on rpi4

I just got started a week ago and everything is running well. I ran out of sensors to configure, but the stuff I have done is working fine.

Out of nowhere yesterday I couldn’t connect to check my AC and when i went to the rpi4 I had lost keyboard to it. I couldn’t restart it cleanly so I powered it off and back on.

It boots all the way up and gets to the login then just keeps printing messages about changing port names and blocking and unblocking ports.

I have no keyboard access and my wifi is not getting an address even though network manager seemed to startup fine.

I pulled the SD card and checked it. Nothing obviously wrong there. Plenty of space on it still nothing out of the ordinary size wise.

My next step is get another SD card and see if I can run normal raspbian to make sure I don’t have a rpi hardware issue.

Any other ideas? Anyone seen this before? I’m assuming there is no recovering from it and I’ll have to reinstall everything which I’m not too happy about after just 1 week of very light use. Hopefully this isn’t common?

What do you mean you have no keyboard access? Can you connect the device via an ethernet cable(which I would suggest anyway for a home automation server)?

If the SD card is fine, you don’t need to reinstall anything, just put it in you new device and done.

Can you see your data on the SD card?
If so, I’d make a backup of the SD card right now if I were you.

I have the RPI hooked up to a monitor and keyboard so what I meant is my physical keyboard no longer works. It’s as if it is blocking the USB port for some reason. Even though it clearly shows that it recognizes the keyboard and that it’s plugged in. I see that in the dmesg at the start and if i unseat and seat the keyboard usb again it spits out that it sees it.

SD card is fine I can make a backup of it no problem. Brand new RPI4 though seems odd that I’d have hardware issue right away.

I will try the ETH plugin to see if that helps. I just find it really strange I can’t use my keyboard. Maybe the hardware issue I’m having is the wlan0 though and if so possibly causing USB issues.

Will definitely have to send the rpi back though

First try with a new sd card as you wanted to do anyway :wink:

I would agree here with @Burningstone (I often do :rofl: )
Your post looks in conflict as the Pi should NEVER have a keyboard connected.
HA runs a web server via it’s local IP address and should look like this
You sate you’ve have stuff up and running and have configured devices.
I’m not sure how that is possible given what you’ve said.
Please explain it very slowly, I’m stupid :rofl:

Keyboard was working fine and you can actually get on the system and mount the file systems. I did it that way to configure my wifi.

It’s worked since day one. I have a motion sensor, it’s hooked to my cameras, it’s hooked to my AC, and I have a zwave/zigbee device that has been working fine.

I’ve got a couple automations and a script to set the initial state of my motion sensor.

It’s been flawless. I’ve had to learn how to do all that stuff which has taken almost 2 weeks worth of daily jacking with it, but as I said it’s flawless.

When I couldn’t connect to it via the web and I couldn’t ping it I have no choice but to see what is happening on the screen. The keyboard no longer works nor does the wifi.

Not sure why you wouldn’t want to have a keyboard on a pi that doesn’t make sense to me.

I only use a keyboard on my home assistant server when there are some serious issues with the host machine otherwise I don’t need to touch it, running two years now and I didn’t have to attach a keyboard once.

I highly suggest using ethernet for your Pi, WiFi is not reliable enough, slower and can cause problems as it seems in your case.

HA is designed to run ‘headless’ this means no monitor and no keyboard.
I know that if it’s running in a docker (other than hassio) or a venv, you can connect via the host system.
But as burningstone says, I have NEVER connected a keyboard into any pi I have (last count I had 14 from 0’s, 0w’s, 2’s, 3’s and a couple of 4’s) everything is done either via ssh or Web.
The ui is via the Web and you can do a lot more from there.
I’m assuming that you connect via then from your host?
If that (your host) doesn’t like the keyboard, that’s not an HA issue, try connecting from another pc/tablet/phone (I’ve used them all)
Report back

Mutt. You aren’t following me here bud. I know how it’s supposed to work. I am developing the whole thing from another computer. I realized it was offline because I was on my tablet with the HA app and it wouldn’t connect.

I have it with a “head” so that I can troubleshoot and as someone who has been using linux since 1998 I am much more comfortable on a command line than I am jacking with fat partitions on my SD card or w/e the strange setup was in the “getting started” section to get networking going.

All that being said it looks like it was something with the wifi that had the system locked up. I plugged it in directly to my router via ethernet and it came right up.

I find the behavior very strange though that wifi suddenly not working and seemingly locking up the usb ports.

Hopefully just a wifi related fluke. Thank you @Burningstone for the advice & @Mutt for trying to understand my issue.

1 Like

Glad you got it sorted.
Can’t think of anything anything that would cause wifi to go down other than disabling it direct from the base OS (which I assume you didn’t do).
Using eth0 (or whatever they have recently decided to name it) is definitely the way to go as it’s far more robust, lower latencies and higher bandwidth (as you know).
It’s very hard to determine how best to help most people because you have no common shared history, no idea how they have installed or how they are attempting what they are ‘sort of’ talking about.
We have to assume we need to start from scratch, sorry if this offended you.
If you are happy with a command line then use ssh, if and if only ‘most’ of the programs have crashed, ssh still works.
Though if your keyboard ‘worked’ then didn’t AND at about the same time as your WiFi stopped then… (ie suspicious coincidence).
I have found pi’s to be quite resilient, so always assume user error before hardware fault. SD cards however are as variable as their users …
Good luck