Over The Air Tasmota & Gosund WP5 Plugs

It appears that I have bricked two WP 5 Gosund plugs trying to flash Tuya-Convert OTA. I successfully flashed a Topgreener Switch, however the Gosunds are proving to be problematic. Questions:
1.) Is there anyway to bring the two “dead” plugs back to life?
2.) Can these plugs be OTA (or wired) flashed in the first place?

Thanks in advance for any help that can be provided.

I just flashed one a few days ago. The first time I flashed it I got to the Tasmota config page but after setting up my wifi it disappeared. I held the power bottom to try and reset it and eventually saw vtrust-recovery as a wifi network. I managed to reflash it by getting tuya convert ready and simply unplugging and plugging the plug back in. I’m using a nodemcu as the AP.

I’ve tried holding the power button in as I insert the plug into the outlet. I’ve tried pressing the power button multiple times while it’s plugged in. Nothing seems to bring it back to life. For what ever reason it won’t power up. I’m not sure how attempting to flush a device can render it totally dead. I noticed on the blakadder website that it doesn’t mention that Tuya-convert was used to flash the plug (where as other devices it does). Maybe the Gosund WP5 isn’t flashable? https://templates.blakadder.com/gosund_WP5.html

Do you have any other ideas on how I can re-activate the two dead plugs I have?


I flashed 4 WP5s with Tuya Convert OTA so it works. Makes sure you are plugging one in at a time. Get Tuya convert ready up to the warning message, plug 1 WP5 just plug it in don’t worry about holding anything or seeing any lights and hopefully it starts to flash. The one you flashed is probably ok, once Tasmota is flashed no lights show up or you won’t hear the relay click because it hasn’t been configured yet. Did you ever get the plugs wifi to show up?

WP5 Failed OTA with Tuya-convert using a setup that had worked with other modules.
Purchased from Amazon Nov 4, 2020.
Smart Plug Gosund Smart WiFi Outlet Works with Alexa and Google Home, 2.4G WiFi Only, No Hub Required, ETL and FCC Listed 4 Pack [Upgraded Version]

see the tuya-convert wiki efforts to overcome the new firmware

I just tried to flash 12 of these. 11 worked without issue and one of them seems to have been bricked like OP mentioned. I don’t know any of the following for sure but from watching the behavior of these devices here’s my observations and a guess about what’s going on.

When you plug in these devices from the factory they immediately go into the fast-flashing upload mode. I think I received two batches of devices. Some behaved “normally” and let me download a backup firmware, but others seemed to have no firmware factory installed - or at least the backup link would hang forever, but the device could be successfully flashed. In the case of these latter devices once you attempt any firmware update the device never goes back into the original factory state. The device that was bricked was the only one where the upload of the ‘temporary/intermediate’ firmware failed. In other cases, if that firmware was uploaded successfully the device would boot the temporary firmware after a powercycle.

So it seems like somehow the intermediate firmware is written to the device, and if that fails there’s no mechanism to get the device back into it’s programmable state. I assume if I were to open up my bricked device I’d be able to program from the serial pins, if I’m able to locate them. Not sure I’ve got the time to try it given that I’ll probably destroy the case if I open it, but maybe someone familiar with tuya-convert could take these observations to make a clearer diagnosis of what’s happening.

Hi Mark
Sorry for not seeing your post earlier. I’m no expert at flashing these devices except to say that I’ve successfully flashed 5 of the 12 I purchased. The remaining 7 WP5’s have yet to be flashed. I did come across one quirky trick. I hope I can pass this along correctly. I have the tuya-convert process loaded on a Ubuntu laptop. After launching a terminal session and executing the command cd tuya-convert followed by sudo ./start_flash.shone of the steps is to stop several prompted services. Then I continue flashing the device. Once all is complete I’ll close the terminal session. If I open another terminal session I can’t flash another device; I must reboot the Ubuntu computer and start the flashing process all over again.
I hope this makes sense.

1 Like