Overkiz API and Somfy API

Today I tried to upgrade to 2022.11 beta but the new local Somfy api (still in alpha) gave errors. Where do I report such errors ?

Best is to do this in the GitHub issue. For more slow chat we can create another community topic or handle this on Discord.

Edit: Found answer among the replies above in the thread. For anyone else that missed:

In the api.py file line 330, change to “async with async_timeout.timeout(TIMEOUT):”
After that the pull request link works.

////////////// Orginal msg:
I tried following the steps, installing the pr_custom_component which seems successful, however when I move on to step two entering the link https://github.com/home-assistant/core/pull/71644 within the PR custom component integration I get the following error: “Unable to process pull request link”

Log says:
“2022-11-04 20:37:56.253 ERROR (MainThread) [custom_components.pr_custom_component] Error parsing information from https://api.github.com/repos/home-assistant/core/pulls/71644 - timeout() got an unexpected keyword argument ‘loop’”

Any ideas to what could be wrong?

So I managed to install the local api overkiz mod.

My gateway gets detected among integrations. When I press configure I do not at any point get to choose Hub / local API. I just get to enter my credentials and password and then all my devices are detected.

How do I know if it uses the local API or the cloud? I saw in one of the pictures that the “connected via” is a number for your local one while it says Tahoma on the cloud one.
Mine says TaHoma Switch, which makes me think that I am still using the cloud even though I made the custom install? If so how do I switch over to local?

Same here, integration detects gateway, but offers only username/password. No selection box for anything local.

Let’s discuss the local API in another topic, to not spam this topic with development / testing messages :).

Overkiz integration - Local API [Development / Testers topic] - Home Assistant Community (home-assistant.io)


Few days ago the integration Tahoma Overkiz (by Somfy) stoped working and I’ve install the integration Overkiz. I have a Hitachi Yutaki heat pump witch work with Hi-Kumo. The new intergration by Overkiz is connected to server but I don’t have all the entitis that I had on Tahoma Overkiz. I don’t have the temperatures from the Hitachi pump (air temperature and hot water temperature). Can you help me with this? What I do wrong?

For now you can just use the custom component (ha-tahoma). Can you share which device is not supported in Overkiz in core?

You can install ha-TaHoma and look up your device, and share the hardware info of that device here.

Hi community,

I’m totally new in the home assistant community, so I’m really sorry in advance if I do thinks the wrong way.

I have several Thermor air heaters at home and I have bought the Thermor Cozytouch Bridge (from Thermor shop). I have added my devices on the Thermor Cozytouch Android/IOS app, and I can also see the same devices configuration in the Atlantic Cozytouch app with the same credential (it looks like it is exactly the same backend).

My Homeassistant is a core version running on a python venv (2022.11.2/20221108.0) and I tried to configure the native Overkiz integration and also the HACS Overkiz integration (v2.14.0).
For both integration, when trying to configure/login to the Atlantic Cozytouch Hub, I have these errors when providing my email/password: “Mot de passe ou nom d’utilisateur incorrect” (Native Integration) & “Authentification non valide” (HACS).

I’m not familiar with homeassistant debugging, do you know if some logs are generated somewhere to investigate the issue? Should I open an issue in the HA (Issues · home-assistant/core · GitHub) or Overkiz github (Issues · iMicknl/ha-tahoma · GitHub)?

Thanks a lot for your kind advices,

If it doesn’t work in both, I would create an issue in core integration. However, errors around invalid authentication are hard to debug for us, since we cannot generate a log.

For that case, if you have created an issue, you can also contact us on Discord and we can see if we can debug it on our side.


Now it is OK. I don’t know why it stopped working though. That’s what I had until now and it was ok, until it told me that the integration is outdated.

I have attached what I have now as devices, what is circled in red does not appear in Overkiz in core.

Ok, thank you for your answer, I’ll do so then !

I’ve been using this integration for a while and it works great, but why do I have to continually re-enter my Somfy password all the time manually? it’s really annoying as it can obviously affect my automations.

It can last for 12 hours or up to 2 weeks. Most of the time I’m re-entering the password every few days. Surely there’s an easy way to save my Somfy password somehow and just get it to reauthenticate automatically if needed?

Which server / hub do you use? (The one you pick when you configure the integration).

it’s a Somfy Connexoon hub and I’m connecting to Somfy Oceania.

1 Like

Known issue. See Somfy (Oceania) needs reconfiguration every few days · Issue #68620 · home-assistant/core · GitHub for a work-around.

1 Like

Thanks for pointing me in the right direction. I should have looked for this work around 6 months ago rather than putting up with it.

Hi there
As I had trouble connecting to Somfy TaHoma in the last days (seems their server was down Inbetween ) and by that I couldn’t handle my Somfy devices during that time, I am curios whether the direct local connection to the TaHoma hub is still coming and whether there is a rough timeline for that.
I don’t want to put up any pressure, I am actually glad that there are people working on all those integrations I use, as I couldn’t do that at all. However would be nice to know what’s in the pipeline.
Best regards

That worked for me too!
Thank you

It just work fine with me with this equipment:
Outside front gate (io:DiscreteGateOpenerIOComponent)
Garage door (io:DiscreteGarageOpenerWithPartialPositionIOComponent)
2 somfy covers (io:RollerShutterWithLowSpeedManagementIOComponent)
4 roof window Velux Covers (io:RollerShutterVeluxIOComponent)
1 motorised roof window Velux (io:WindowOpenerVeluxIOComponent)
1 sun screen (rts:HorizontalAwningRTSComponent)
all working with a Tahoma Switch
this integration is installed on a seperated Home Assistant Instance.

To be continued
Looking forward to seeing this added to core

Thanks for your hard work gents

[EDIT] I forgot to say that during the installation I am proposed several Tahoma devices, all with same PIN; I just chose the first one