Overkiz Authentication Failure

Hi all,

I’ve been having an issue with the Overkiz integration needing to be re-authenticated somewhere between every 1-2 days. I have a Somfy TaHoma Beecon which has Zigbee 3.0 and controls my motorized roller shades. Here are some details of my setup:

Home Assistant 2022.8.7
Supervisor 2022.08.5
Operating System 8.5
Frontend 20220802.0 - latest

Errors I’m Receiving

Logger: homeassistant.components.overkiz
Source: helpers/update_coordinator.py:151
Integration: Overkiz (documentation, issues)
First occurred: August 30, 2022 at 3:49:24 AM (2 occurrences)
Last logged: August 30, 2022 at 9:10:32 AM

Authentication failed while fetching device events data: Invalid authentication.
Logger: pyoverkiz.enums.gateway
Source: runner.py:119
First occurred: August 29, 2022 at 7:13:03 PM (2 occurrences)
Last logged: August 30, 2022 at 8:30:30 AM

Unsupported value 75 has been returned for <enum 'GatewayType'>
Logger: pyoverkiz.enums.gateway
Source: components/overkiz/config_flow.py:60
First occurred: August 30, 2022 at 8:30:29 AM (1 occurrences)
Last logged: August 30, 2022 at 8:30:29 AM

Unsupported value 75 has been returned for <enum 'GatewayType'>

I’m not quite sure where to go from here with figuring out what’s wrong or how to fix it. Any help is greatly appreciated!

Thanks for reporting, @mazarian! Can you share a bit more information about the Somfy TaHoma Beecon? Which hub/server did you choose in Overkiz?

Are you by any chance using another server than Europe? In that case it is probably the same bug as Somfy (Oceania) needs reconfiguration every few days · Issue #68620 · home-assistant/core (github.com).

Regarding Unsupported value 75 has been returned for <enum 'GatewayType'>, this is just a warning, but we will add this GatewayType to our definitions. You are probably the first user with the TaHoma Beecon!

Thank you for getting back to me! There’s always a first and I am 100% happy to do ANY testing you’d like on it. I live in the US and am using Somfy North America for the hub under the Home Assistant configuration. Here are some of the details written on the device:

Contains FCC ID: 2AATL-F23BUUM13
Contains IC: 22008-F23BUUM13
MAC: AC:64:CF:E3:AB:XX (removed last set)

The device supports Zigbee 3.0 and RTS. It is used to control my Screen Innovations roller shades which have a Somfy motor in them. Here’s the spec sheet from Screen Innovations. This device doesn’t support Homekit, which is confusing because I think there’s another Tahoma device that actually does. In order to control the shades using their app, I have to use the Somfy TaHoma app.

Hopefully this is a good start on getting you info! Happy to send any other details your way as well. I intentionally didn’t re-authenticate in case you’d like me to do any specific testing when I do run through the authentication.

Let me know if you need anything else and THANK YOU for your help! :slight_smile:

Thanks! I will add your gateway to the list, for your issue with the reconfiguration, please follow https://github.com/home-assistant/core/issues/68620 for any updates.

Hi Michael,

I just installed the same device and connected it to Somfy North America and I have the same problem. Nearly every day I have to hit the Reconfigure button for the integration.

Did you ever get a fix for this?

Thanks. Tim

Disable polling. (see GitHub issue link above)