Overkiz Somfy Tahoma - How to STOP / Trigger MY POSITION / Read Position?


I really love the Somfy / Tahoma developer Overkiz integration, I could finally manage to open/close my terrace roof and zip screen via Home Assistant, using node red as controlled from KNX.

What I still couldn’t get work are following:

  • How can I stop a cover via Node Red? the integration in dashboard works fine, but need it in Nod Red to control via KNX
  • How can I go to the MY-Position for cover via Node Red? the integration in dashboard works fine, but need it in Nod Red to control via KNX
  • How can I read the current percentage position, it’s showing up in Tahoma App, would be great to have this in KNX.

Thanks a lot

Service Calls.

Covers as entities have cover:open/close/stop

Devices with ‘my position’ have buttons, so button:press

I don’t have devices with position, but io devices (not RTS) should return values, as entity sensors.

Basically, if you can see it in HA as a sensor, you can read it (current state in NR). If it is a button, you can press it (service call on NR). If it is a cover, you can open it, close it, and stop it.

1 Like

Thx for the hint with button, unfortunately still not working. How do I need to configure the rest, if KNX GA is 1 then press button?

My covers are all RTS, and these work from an HA service call as expected.

I can only suggest testing the service call in HA Developer Tools, Services first.

Use a switch node to isolate the 1 message.


What is the error in the debug window on the right hand side? Inside the call service at the very bottom check the output to debug box.

Actually no more error, was maybe another thing that totally stopped everything working. good now, but no matter what I try this button doesn’t work. Can I test if the selected button would work at all? like right click test? :smiley:

Actually it’s working now. Seems Node Red is the problem. It like either stops working or loses KNX connection or something.

I restarted Node Red and it worked.

So only things left for now is cover Stop, doesn’t work as button although it’s shown as one and the state, not sure where I could set the sensor tbh.

Integrations that add devices as covers, add the service call under the domain ‘cover’.

If you check in HA first, see if the service ‘cover’ as close or open or stop will accept your cover entity.

The ‘my position’ is a button, covers are not buttons

The STOP is shown as button, not as cover actually?

Now I found the position sensor in percentage, were hidden. Which node do I need to use to write this to a percentage format in a KNX GA?

thanks for your help

In my integration with RTS blinds, they are added as covers. In HA covers are shown specially on the dashboard with ‘buttons’ for open, stop, and close. However to make the cover open, stop or close requires a service call. HA does this from the dashboard, otherwise you call the cover:open service. Same from Node-RED, it is a service call to domain ‘cover’

Glad to hear that you found the percentage sensor. Many integrations add less used entities as disabled. Sorry, but I know nothing about KNX GA, so perhaps someone else can help you.

As a general guide, the HA websocket nodes - current state - can be used to read the state value of any HA entity.