Owntrack HTTP component missing dependicy

Hello everyone,

I encountered a problem with owntrack HTTP, homeassistant is reporting that i’m missing some dependicy.
Now, everhing was working correctly until last week, I’m not sure exactly if the homeassistant update broke it or something else…

Configuration in configuration.yaml is pretty simple:

- platform: owntracks_http
  track_new_devices: yes
  waypoints: False

This is what homeassistant is reporting in logs on startup:

2018-12-04 15:35:32 ERROR (MainThread) [homeassistant.loader] Error loading homeassistant.components.device_tracker.owntracks_http. Make sure all dependencies are installed
Traceback (most recent call last):
File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/loader.py", line 92, in get_component
module = importlib.import_module(path)
File "/usr/lib/python3.6/importlib/__init__.py", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 994, in _gcd_import
File "<frozen importlib._bootstrap>", line 971, in _find_and_load
File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 678, in exec_module
File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/device_tracker/owntracks_http.py", line 15, in <module>
from homeassistant.components.device_tracker.owntracks import (  # NOQA
ImportError: cannot import name 'PLATFORM_SCHEMA'
2018-12-04 15:35:32 ERROR (MainThread) [homeassistant.loader] Unable to find component device_tracker.owntracks_http

Just for reference, here’s a copy paste from component python file

 from homeassistant.components.device_tracker.owntracks import (  # NOQA
 PLATFORM_SCHEMA, REQUIREMENTS, async_handle_message, context_from_config)

I’m not sure how to fix this, I’m afraid to change something in code because in my expirience that will only lead to more trouble :slight_smile:

Also, I didn’t find any topics with this specific problem so I’m out of ideas :frowning: Please help, thank you!

Are you on 0.83 or above? If so, you need to enable OwnTracks in the settings. The documentation on this was only recently updated. Go to Configuration --> Integrations then scroll down and select “configure”. After selecting configure you will be prompted with instructions on how to configure OwnTracks using HTTP. You don’t need to include anything in your configuration.yaml. In fact, I’ve seen other users reporting that they’re having issues when including the OwnTracks platform in their configuration.yaml file.


That’s it, I totally forgot to check configuration tab. Thank you, it’s working now! :slight_smile: