[Owntracks] Duplicate device tracker

Hello people,
Since the upgrade to 0.94.0 I noticed that my GPS device tracker updated by Owntracks (let’s call it “trackergps”) hasn’t been updated. So I went to the entity list and noticed another device tracker was created called “trackergps_2”.

I did notice the breaking change about device trackers in the release notes, but the question is: how do I make it update the original one? Or, if I can’t, how can I use the original name for the new entity? I don’t want to change the whole configuration because of this (and I would be forced to keep a stale entity anyway).


I think you need to delete the ones from known_devices.yaml and restart.

I plan to do this when I get home from work this evening if you want confirmation before you experiment.

1 Like

Ok I just did that and the old stale device disappeared, thank you. However, the new entity is still present with _2 suffix. I could of course put my hands on the database, but if you or anyone knows a polite way to fix…

Yeah, go in to configuration > integrations > owntracks and see if you can change the entity id in there. If not you’ll need to (carefully!) manually edit the entity registry in .storage to remove the _2 from each one.

1 Like

It worked perfectly, thank you!

P.S. @anon43302295 do you mind combining the two responses (removing device from known_devices + rename entity id from UI) into one message so I can mark that as solution to the post please?

1 Like

I saw the same thing with my mobile_app.
I renamed known_devices.yaml, restarted HA, and the fixed the entity names just as suggested above.
Everything is back to normal now.


1 Like

Thank you for the fix – I have been removing from entity registry to no avail. Commenting/removing the devices in question from known_devices.yaml worked.

However, how can I simply re-add the devices into known_devices.yaml file? I ask because I was using a name and picture inside that file for those devices. Is this still possible?

The new version of the integration doesn’t use known_devices, you’ll have to have a look in the integration for those options or use customize.

Thanks!! I must’ve missed these details in the changelog. Have a good one :call_me_hand:

@anon43302295 , that can’t be completely true, as 0.94 created known-devices.yaml by itself, when I updated the file with friendly names etc, all entities updated…?

It can be true, because it is true. Known_devices is still used by other device trackers so it is still required, but owntracks doesn’t use it.