Owntracks - MQTT home region exit via loss off iBeacon does not tracker to "not_home" / "Away

I have been integrating owntracks recently into my HA installation as the final input component to overall presence detection.

Owntracks on HA configured as follows:

zone: !include zones.yaml

max_gps_accuracy: 2500. (this is set so high as I am in a big building and when I go down the lift, the gps accuracy explodes from a normal 65m to anywhere between 200 and 3000 during lift ride
waypoints: false
mqtt_topic: “owntracks/#”
events_only: true

XXXYYXXX - name of region on my owntracks app on my IOS platform
XXXYYXXX - is also an iBeacon I have set up properly in owntracks app on IOS, it is set up properly  via radius = 0, valid UUID and Major / Minor and also toggles properly as an antenna from blue to red when it can see beacon, so all is good here

I have “debug” setting as follows in HA and can see all the logs coming in:
default: critical
homeassistant.components.owntracks: debug

my home zone zetting in HA is overwritten as follows in my zones yaml config as follows:

  • name: Home
    latitude: nn.28728000000
    longitude: nnn.1451100000
    radius: 0
    icon: mdi:home

radius is set to 0 as home zone HA is mapped to an iBeacon region of radius 0 on the owntracks app

I am 100% for sure receiving all MQTT messages in HA and know I have my MQTT working flawlessly.

When I exit home zone, and do not enter enter other zone, HA receives the zone transition-exit-region message properly, but will not set the tracker to “not_home” / “Away” in home assistant. I am not sure why. not_home only gets set after I enter another region and eventually exit that region.

Help ? How do I make HA set the status to “not_home” / “Away” as I am no longer at home and also not in another region.

Below are the relevant logs from HA:

“2021-05-16 07:11:47 DEBUG (MainThread) [homeassistant.components.owntracks.messages] Received {’_type’: ‘transition’, ‘acc’: 65, ‘created_at’: 1621120302, ‘desc’: ‘XXXYYXXX’, ‘event’: ‘leave’, ‘lat’: nn.286942, ‘lon’: nnn.145364, ‘rid’: ‘c95980’, ‘t’: ‘b’, ‘tid’: ‘BL’, ‘tst’: 1621120203, ‘wtst’: 1620453194, ‘topic’: ‘owntracks/xxxxxxxx/BRLIP12/event’}”

"2021-05-16 07:11:47 INFO (MainThread) [homeassistant.components.owntracks.messages] Exit to GPS

2021-05-16 07:11:48 DEBUG (MainThread) [homeassistant.components.owntracks.messages] Received {’_type’: ‘location’, ‘acc’: 65, ‘alt’: 97, ‘batt’: 99, ‘bs’: 1, ‘conn’: ‘m’, ‘created_at’: 1621120302, ‘lat’:nn.286942, ‘lon’: nnn.145364, ‘t’: ‘b’, ‘tid’: ‘BL’, ‘tst’: 1621120203, ‘vac’: 10, ‘topic’: ‘owntracks/xxxxxxxx/BRLIP12’}

2021-05-16 07:11:48 DEBUG (MainThread) [homeassistant.components.owntracks.messages] Location update ignored due to events_only setting"

logs show HA receives the region exit and knows it came from an iBeacon, it also ignores subsequent location update by design and settings of the owntrack integration.

Thanks !

Brendan Leitch