Owntracks, MQTT


I’ve been forced to re-install my HA-installation :frowning: My PI4 crashed and wouldn’t boot (and real men do not make backups, they cry :smiley: )
This means that I have had to re-setup everything (almost).
One of the things I’ve re-done is the MQTT and Owntracks setup. It worked beforehand and my devices (iPhones) published their location via Mosquitto MQTT topics using owntracks app on the phone.
I configured MQTT in GUI of HA to connect to my Mosquitto server (running in another Docker container on the same Pi). The connection works and when I publish my location via the app and Mosquitto, it’s visible to HA’s MQTT integration when I use the MQTT configure → listen to topic, it picks up just fine.
I’ve added

  max_gps_accuracy: 200
  mqtt_topic: "owntracks/#"

to configuration.yaml.
But no devices show up in HA after several restarts :frowning: the only device_tracker entity I have is the one from my HA iPhone app (and I do NOT want to use this for locations - I want Owntracks / MQTT)

Any takes on what could be wrong?


Solution: remember to add Owntracks integration from GUI as well. Then it works like a charm I f one add the settings from the first post.

I have Home Assistant running in a docker installation. I added Owntracks in another docker container. Owntracks on my Iphone is working and I can get the gps coordinates in home assistant via mqtt in node red. I tried to install the owntracks integration but get an known error. I suspect it’s a docker home assistant problem. Does anyone have a solution.