Owntracks stopped working

So I have owntracks set up on my android phone and have been using it as a device tracker with home assistant for about six months. I have it connected to a cloudmqtt and then bridged to my HA mosquitto server. It was working just fine for months but just last night it gave me an error (HA also shows my status as “home” now, I’m not at home). When I check the error on the app it says:

Endpoint state

Not authorized to connect (5)
Endpoint state message

Endpoint queue

I have tried uninstalling and reinstalling the app, reentering my host information and creating a new user and ACL on cloudmqtt to no avail.

I haven’t changed any of my HA settings in weeks and everything was working normally up until this point so this seemingly random error has me baffled.

Ok so a small update on this. I was able to get it working again by changing the cloudmqtt user to a different one. I then changed it back to my original user id and it continued to work for about an hour, then gave me the same error.

I have since switched to the new user and it is working again. So I suppose I have a work around to continue with it working. I would just like to know why it is doing this in the first place?

sounds like an issue with CloudMQTT/Owntracks and not Home Assistant. Probably best to contact them for a resolution on why a user/pass would stop working.

Likely, however when googling to attempt to find a solution I came across a post with someone who was having a genuine issue and wasn’t sure why with owntracks and I believe it was the developers were posting to find a solution, but the way they were posting came across as arrogant and unhelpful when the person was genuinely confused with what was going on. So I figured I would try here first before diving into that.

Yeah, just didn’t want you to wait around here for a solution if it’s just something with your account on CloudMQTT