(OZW) Fakro ARZ roof window roller shutter showing up as ZWS12 chain actuator

This is most likely an issue with OpenZWave, but I noticed that my Fakro ARZ Z-Wave roof window roller shutters are showing up as Fakro ZWS12 chain actuators.

The weird thing is that OpenZWave correctly lists the ARZ Z-Wave shutters as Product ID 2 and Product Type 2, whereas the ZWS12 chain actuator appears as Product ID 1 and Product Type 3.

However the current OZW library doesn’t yet include a product profile for the ARZ Z-Wave roller shutters, as can be seen in e.g. lib/python3.6/site-packages/python_openzwave/ozw_config/config/manufacturer_specific.xml and in lib/python3.6/site-packages/python_openzwave/ozw_config/config/fakro/

Any suggestions in fixing this incorrect product assignment?

An XML description of all certified Fakro products can be found at the Z-Wave Alliance.

Following up on this matter, it appears that the function logic is also inverted: when the roller shutters are down they show up as opened.

The identification problem is a hardware/firmware error made by Fakro.

I have 3 ARZ devices and 3 ZWS devices. Those devices identify themselves as:

ARZ Shutters
ID 0x0001 Type 0x0003 - Fakro ZWS12 Chain actuator 12VDC
ID 0x0002 Type 0x0002 - Fakro ARZ Roof Window Roller Shutter

ZWS12 Windows Openers:
ID 0x0001 Type 0x0002 - Fakro Unknown: type=0002, id=0001
ID 0x0001 Type 0x0003 - Fakro ZWS12 Chain actuator 12VDC

What you can see is that I have both an ZWS12 as well an ARZ, both identifying themselves as ID 0x0001 Type 0x0003.

Probably Fakro made a mistake in their firmware. How to tell them about this error, and convince them. I already tried to mail them about this issue in 2018, but without any responds. They simply ignored my email about this.

Now I’m reading more people are having trouble with ARZ devices recognized as ZWS12.

Because it is an Fakro mistake, this can not be solved in OZW, openhab, domoticz, home assistant or whatever. Users of those devices need a software update, or a new device covered under fakro warranty, because it is an production failure.

I sent an email to Fakro about this problem, for the second time, and this time I received an answer:

Beste heer van Benthum,

Een aantal jaar geleden zijn er inderdaad problemen ontdekt met de identificatie van een aantal producten, op basis daarvan zijn er wijzigingen doorgevoerd (november 2016) en zouden de producten onderstaande identificatie moeten bezitten:

ARZ Z-Wave: TYPE: 0x0003, ID 0x0001

ZWS12: TYPE: 0x0002, ID 0x0001

Indien uw producten dit niet bezitten en dit voor u een probleem vormt met de configuratie hiervan of anderszins dan kunnen de drivers van de producten een update krijgen.

De update kan echter alleen door de serviceafdeling op onze fabriek worden uitgevoerd en dit houdt in dat de producten hier dan retour naar moeten.

Indien u hiervan gebruik wilt maken verneem ik het graag, en ontvangen wij vervolgens de producten graag hier bij ons in Nederland, zodat wij kunnen zorgen dat de update wordt uitgevoerd en u de producten weer ontvangt.

Alvast bedankt.

Luc Bonnet | Technisch adviseur

[email protected]

They tell there was indeed an error, they discovered in 2016, en changed the device identification numbers from 2016.

It means that ZWS12: TYPE: 0x0003, ID 0x0001 is the wrong combination. Every ZWS12 showing up with 0x0003, ID 0x0001 is wrong. Fakro tells it can update the device software, but therefore the module needs to be returned to Fakro.

To solve the trouble with the duplicated in the open z-wave database, the ZWS12 with TYPE 0x0003, ID 0x0001 should be removed, and only ARZ Z-Wave: TYPE: 0x0003, ID 0x0001 can exist.

People with faulty ZWS12 should contact Fakro to solve the problem, if the have trouble with operating the device properly.


Was this ever solved, I have 2 x Fakro roof windows with 230v actuators that show up as Type = 0002, id = 0001. They will operate with a Aeotec USB stick but don’t respond back with opened or closed. Any ideas on how to get over this please.