OZWD Won't Connect to MQTT

My system is fully containerized. The issue I have is that my OZWD times out when connecting to the MQTT broker and restarts. My MQTT is working insofar as the test that runss in HA (under MQTT Configure) shows that it can publish and receive the message. But no matter how much I Google I cannot figure out how to get OZWD to talk to it. I do see in the MQTT log that a client is connecting but OZWD times out waiting for MQTT to be available. I am at my wits end and would appreciate any help!

My docker-compose.yaml is as follows:

    container_name: home-assistant
    image: homeassistant/raspberrypi3-homeassistant:stable
      - "8123:8123"
      - /home/pi/homeassistant:/config
      - TZ=America/New_York
    restart: always
    network_mode: host
      - mosquitto
      - ozwd
    container_name: "mosquitto"
    image: eclipse-mosquitto:latest
      - /home/pi/mosquitto/data:/mosquitto/data
      - /home/pi/mosquitto/log:/mosquitto/log
      - /home/pi/mosquitto.conf:/mosquitto/config/mosquitto.conf
    network_mode: host
      - "1883:1883"
      - "9001:9001"
    restart: always
    image: openzwave/ozwdaemon:allinone-latest
    container_name: "ozwd"
      - seccomp:unconfined
      - "/dev/ttyACM0"
      - /home/pi/ozw:/opt/ozw/config
      MQTT_SERVER: localhost
#      MQTT_USERNAME: ""
#      MQTT_PASSWORD: ""
      USB_PATH: /dev/ttyACM0
      - "1983:1983"
      - "5901:5901"
      - "7800:7800"
#      OZW_NETWORK_KEY: "0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00"
    restart: always
      - mosquitto

My mosquitto.conf file is as follows:

persistence true
persistence_location /mosquitto/data/
log_dest file /mosquitto/log/mosquitto.log
allow_anonymous true

What am I missing that would allows OZWD to connect to MQTT? Thanks!

Incidentally, if I should have posted this elsewhere or if there is someplace else I should have looked, please let me know. Thanks.

Try rolling back mosquitto to 1.6. “latest” is 2.0 and I think it might have breaking changes.

Thank you. After a great deal of banging my head against the wall, I think I’ve realized that a fresh HA install should go with the Zwave-JS integratuin instead of the OpenZwave Beta that I was trying to use. Is that correct? Is the path forward going to be ZWave-JS? If so, I’ll just turn my attention to making that work instead of this. What are your thoughts? Thanks.

Changing image: eclipse-mosquitto:latest to image: eclipse-mosquitto:1.6 in your docker compose and recreating the container takes probably a minute at most. That may have you up and running right now.

Personally I’ve switched most of my network to zwave-js (second USB stick), although I had absolutely zero problems with OZW. It worked great for me, and still does for the few devices I can’t migrate yet.

Good point about the ease of making a change. It’s definitely one of the best parts of containerizing everything. Also, I had the same connectivity issues when using zwavejs2mqtt with the MQTT piece enabled so I guess it’s the same problem and I am going to have downgrade anyway. My point, however, still stands that if I am starting fresh, ZWave-JS is the recommended approach, correct?

I know this is off-topic, but where does ZWave-JS store the device configuration files? Or, to ask another way, where do I post questions about getting my Zooz ZEN34 to work since it currently comes up as an unknown device? Thanks.