Pairing an end device through another router


I have been adding zigbee end devices and connecting them through the routers. Now that I want to move the location of some of the end devices, and they become far away from their original router device. Is there a way to move their ‘connection’ from one router and connect it through another router?

Or do I have have to remove the end devices from the zigbee network and pair again?


Some devices will eventually find a better route. Others (like Aqara) wont. For the latter yes you have to re-pair them in the new location.

Using zigbee2mqt I’ve found I don’t have to remove them first. I can just pair them again in the new location.

I’m using zigbee2mqtt too. So how do I pair them to another location? (Do I need to press the pairing button of the end device for 5 seconds and then pair through another router and will move over to the new router?)

But doesnt pressing the button reset the device?

In zigbee2mqtt use the dopdown box to permit join, either “all” or through the router you want, then pair the device in the new location by following the manufacturer’s instructions. For Aqara devices this is pressing the button for 4-5 seconds.

If the device resets just try the pair process again.

Thanks! I tried it and it worked.

Is there a way to keep the entities of the devices the same? I have them on the dashboard and automations and no that I connected it again, those automations and dashboard is not working anymore.

(also the device name and entities have reset to default. So if the above is not possible. can I simply change the name of the device and its entities to what it was previously, then the dashboard and automations will work again…)

You can change the name in zigbee2mqtt. Click on the blue pencil icon on the right of the device row. Make sure to switch on the “Update Home Assistant Entity ID” button.

Thank you for this thread… was very helpful to get my device going through the router. Did you find that when you went to re-pair the devices that they “left the network” and it took several tries before you could get them re-connected?