Panel iFrame not working

I cannot seem to get iFrames to work within my front end.

I tried adding a couple, one for my router admin page, and one for pi-hole admin page

When I click them, nothing. Literally nothing loads, just a blank page?
excert from my configuration.yaml below

panel_iframe:
  router:
    title: 'Router'
    icon: mdi:router-wireless
    url: 'http://<IP_ADDRESS ROUTER>'
  pihole:
    title: 'Pi-Hole'
    icon: mdi:raspberrypi
    url: 'http://<IP_ADDRESS PIHOLE>'

should point out, I am not using any SSL or certification at all, and access my frontend only from within my home network…occasionally from outside via a vpn connection (OpenVPN)

The only thing I do different from yours is that I don’t put quotes round my urls.

hmmm, interesting.
I based my config entry on the documentation, which uses quote marks?
Ill try removing them and see if that does the trick.
https://home-assistant.io/components/panel_iframe/

Didn’t read good enough, sorry…
Try checking what the console of your browser tells you, F12 on chrome.

It works both ways on mine 0.58.2 Hassbian

I’ve just tried to remove the quote marks from my url and still does not work.

fyi, im running latest HAS version on a Pi3, updated to stretch lite.
Home Assistant was installed with a python virtual env.

What flavor of HA are you installing? Hassbian, AIO, Hassio? Not that I think it should really matter as they should all be able to use an Iframe.

I installed it via the python virtual env.

I have now managed to get one working. Its a basic php site I setup on a second Pi.
But I am not able to use a panel with my home router, or pi-hole admin dash or any site, for example https://www.bbc.co.uk
Most strange…why would some sites work and not others.
Pi-hole for example I tried http://pi.hole/admin and http://192.168.0.45/admin and neither work
yet if I use http://192.168.0.45/pisysinfo (which is my basic php site) it works?

I’ve never been able to get http sites to work in a panel iframe. Though I would like to know how to access via VPN…

Its bugging me now…as I have one http site working - my php site, but nothing else?

I installed openvpn via PiVPN, it was a piece of cake, and I use OpenVPN to access my network whilst im away and to connect the Pi on which it is installed, to my VPN provider (PIA)

1 Like

Ah okay that’s easier than I thought I may go that route and get rid of my DuckDNS setup as it seems to be causing a lot of connection issues with certain platforms… Also that is strange, I know I could not get my router page to show up or pihole just like you.

I think you’ll still may need a DuckDNS address if you ISP doesn’t provide a static external IP.
(mine doesn’t and it often changes at random)

I have a DuckDNS address, which is referenced within my OpenVPN configs, I forget where exactly.
I also have a script running via cron on the Pi to check if the external IP assigned by my ISP has changed, if so update DuckDNS

Same issue here, if you press f12 on your browser and look at the warnings you will probably find the sites are not permiting being displayed in an iframe

Refused to display 'http://10.0.0.11/zabbix/' in a frame because it set 'X-Frame-Options' to 'sameorigin'

interesting, I did not look at this.
any way to change this in a self hosted php site?

you would need to take the security headers out of the PHP site, eg stop it returning the “X-frame options” line … will depend on the software / server version how you do that

1 Like

ok thanks.
Think this is beyond my very basic knowledge!
I am only running a very simple php site on my pi-hole which displays system info.

Hi
I am trying to include iframe for my BlueIrs cameras page. when I say my BlueIris what I mean is the URL similar to this http://192.168.0.21:81/jpegpull.htm which I could use from any PC in my home network to view Blue Iris (9 cameras set up).

For some reason iframe come with a blank page. I have few Ifames in HA working (router, Access Point and Node Red). I never got to get my Synology NAS to iframe as Synology system does not allow.

My Config

panel_iframe:

nodered_flows:
title: ‘Node-RED Flows’
url: ‘http://hassio.local:1880
icon: mdi:nodejs

router:
title: ‘Huwai Router’
icon: ‘mdi:router-wireless’
url: ‘http://192.168.0.1/’

tp_linlk:
title: ‘TP_Link AP’
icon: ‘mdi:router-wireless’
url: ‘http://192.168.0.254/’

blueiris:
title: ‘Blue Iris’
icon: ‘mdi:cctv’
url: ‘http://192.168.0.21:81/jpegpull.htm

I also tried URL: http://192.168.0.21:81/login.htm?page=%2F%3Fpage=%2F%3Fpage=%2Fuser=admin%3Fpwd=admin%2F

still same result
Anyone could help

Hi,

I had the same blank page problem with Blue Iris. Solved it by changing the settings in Blue Iris: options, webserver, advanced, allow iframe tags.
Works like a charm now.

If your HA is running on HTTPS, then your iFrame only loads HTTPS pages

2 Likes

Holy thread resurrection Batman!
:wink:

1 Like