Paring tradfri remote with zha / elelabs zigbee shield

Old thread, but for those still looking.
The E1524 is support and can be paired to ZHA (with some luck and randomness)
After being paired, button presses will trigger zha_event
You can ‘monitor’ these events via Develops Tools > EventS


I followed the steps to pair the 5 button remote with ZHA and I see the device created with just the one entity for power. I am not seeing any events coming through from the remote when I press any of the buttons (I am listening for events as described above). Any further tips on how to get the button presses to be recognized? I am using 2021.07 version of home assistant core.

@zraken Any luck getting the events to appear? I am facing the same issue. @DavidDeSloovere Any tips will be greatly appreciated!

Thanks in advance!

Nope, still no zha_event. I tried different firmware versions on my tasmota sonoff zigbee bridge as well as a HUSBZB-1.

1 Like

Hmmm! I also have a sonoff Zigbee dongle CC2531 connected to my RPi to manage my Zigbee. Could the sonoff hardware be the issue?

I suspect the zha integration is not handling the zigbee button press event. With zha debug enabled I see a debug message pop up on the log whenever I press a button but nothing happens after that.

Mine worked ONCE, just once. Then nothing. I suspect my Sonoff Zigbee dongle can’t handle the number of devices I have, or something similar. I tried reconnecting the remote with a new battery even. Something strange I noted: even a feet away from the TRADFRI repeater its connected to, the remote has very low LQI and unknown RSSI.

Hey Guys, i use the “Elelabs Zigbee Raspberry Pi Shield” and had the same problem.

This works for me:
Open the back of the tradfri remote, and press the button 4 times (the red light in front will blink for five seconds).

Now in Home Assistant: Scan for new devices (in my case with “Zigbee Coordinator” under “Devices”) and bring your remote close to your Raspi. Now press the button on the back of the remote 4 times and if nothing happen, press it again 4 times. Then the remote should appear in your HA Backend and you can add it.

I hope it will also work with other zigbee devices.
I created a few automations with different Buttons (e.g. toggle lights or open my garage).

I have been able to pair the device and it shows up as the IKEA remote under zigbee devices, the problem is that I’m not getting any event when listening to zha_event.

I have not used the tradfri remote in HA, because it wasn’t worth my time.
Just noticed it’s still in Home assistant, but no zha_events anymore.
The dimmer is linked to led panels in my kitchen; but I’m getting a new kitchen in a few weeks, so I don’t know what I’ll do with the dimmer…
The dimmer as a rotating dial would be great for some volume control, but then again, other remotes work better (or actually work). Like the 5 button ikea remote, via ZHA (this one doesn’t throw events, but can be used as Device in the trigger of an automation).

Thanks. TRADFRI Remote is the IKEA 5 button remote. It is their Zigbee brand name. You say it is not throwing events but can be used for automation. Can you explain how it can be done and how a button press can be captured?
Thanks in advance.

Trigger Type: Device = awesome

Thanks. The issue is, I don’t see any actions when I try automations using the TRADFRI remote. The actions dropdown is grayed out.

The hardware design of your ITead Zigbee adapter is almost 100% an issue too, so be sure to read this:

The MCU chip they use is very powerful so can handle loads of connected devices, but the antenna design and unshielded board they use have huge issues with electromagnetic interference. Again read:

Thanks for the screen shots, I do see the trigger options but nothing gets triggered on button presses. I am using the Sonoff stand along bridge which is tasmotized (not using the dongle).
Pairing the device almost always is successful and I see the power level updates being recorded correctly, just that the button presses are not coming through.

Thanks @Hedda . This is my hardware info:
ZNP = Texas Instruments Z-Stack ZNP protocol: CC253x, CC26x2, CC13x2
by ZHA


I read in another thread TI CC2530 is a good device. It seems the hardware mentioned in the thread you shared is different. I am confused!!!

Sorry, I read wrong. I thought that you had a Itead Zigbee 3.0 dongle and not their old CC2531 dongle.

CC2530/CC2531 is based on old obsolete MCU/CPU hardware so not recommended for ZHA.

MCU/CPU in the C2530/CC2531 is not powerful at all so not recommend for more than 15 devices.

C2530/CC2531 with Z-Stack Home 1.2 is OK for Zigbee2MQTT with more devices if use many routers.

Zigbee2MQTT does however no longer recommend C2530/CC2531 because of its slow hardware.

That is, C2530/CC2531 with Z-Stack Home 1.2 is good enough for Zigbee2MQTT but not good for ZHA.

Suggest that you buy better hardware if you ever plan on adding more than 15 Zigbee devices.

Regardless, be sure to follow these tips:

and these tips too:

Thanks. Any specific hardware is known to work really well with HA on a RPi?

I was able to workaround the issue with some limitations though (no color temperature control). Here how I got it working:

  1. Enable ZHA
  2. Pair the remote (4x presses on the pair button then press any button while pairing to prevent it to go to sleep)
  3. Pair a bulb
  4. Remove ZHA integration (not sure if it’s needed)
  5. Launch zigbee2mqtt, pair the devices there, update firmware on the remote, unbind it from the default group, create a “magic group”, bind the remote to the group. Detailed description. After that you will get your remote and bulb binded.
  6. go back to HASS
  7. Add ZHA integration if you removed it earlier
  8. Everything’s working (except color temperature control and zha_events apearing in HA).

I’ve failed to setup scenes as described on the zigbee2mqtt page to get the color temperature changing working with scenes. Will update if I will be managed to.

Sorry for the very late response. I see every zha_event when i press the buttons (wiht Elelabs Zigbee Rasp…).

At the moment, i have the following problems:

  1. I think the battery wont goes empty quickly
  2. If the device is not connected (empty battery), you have to add it again (even if the data remains stored in HA, it is unnecessary effort).
  3. I guess, if the device is outer reach (e.g. in my car to use as car remote), the connection is also disconnected.

I will therefore look for another remote solution (possibly with WiFi).