Paring tradfri remote with zha / elelabs zigbee shield

I am trying to get a trasfri remote working directly with home assistant zha without the tradfri gateway. I am using elelabs zigbee shield - which is working fine with several tradfri spots and some xaiomi zigbee devices.

But I cannot get the tradfri remote to join my network. My approach:

  1. Reset the remote (pressing the button 4 times quickly)
  2. Permit Join in home assistant
  3. hold the remote near to the shield and hold down the button for at least 10 seconds

I am using the following config for logging:

  default: warn
   homeassistant.components.zha: debug
   bellows.ezsp: debug
   bellows.uart: debug
   zigpy.zdo: debug
   zigpy.application: debug

But no logs at all appear during my paring tries.

I have found several post that say they got the remote working but they all were using the deConz zigbee stick, so I guess it it should work.

Any ideas how to debug the problem?


I pressed the remote pairing button 4 times and after that it paired via zha. Can’t actually do anything with it yet…

I updated home-assistant and now I could pair it as well.

But button presses are not received by home-assistant.

@winter The 5 button remote is currently not supported by home assistant, see

1 Like

I was trying to patch this and I noticed that the remote is included in zhaquirks. Testing with debug logs enabled, there are events on zha_event that include the button pressed, although with unusual naming:

  • toggle: the main button
  • step_with_on_off: Brightness up
  • step: Brightness down

The other two buttons weren’t visible in zha_events, but i got stuff from zigpy.zcl that might be useful. For now i’ve just added automations to listen for button presses.

1 Like

Hi, can you please share an example of your automations listening to button presses?


Had trouble figuring this out, what I did was build a device automation through the automation UI in HA. The only thing was that I was doing all other automation through manual yaml (old school, I know). So it wasn’t saving the automation in my list, but it did save the automation in the “automations.yaml” file in the config folder. There, I found this code:

- id: 'xxxxxxx'
  alias: TEST Ikea Remote
  description: ''
  - device_id: 3365d095fad84ebxxxxxxxxxxx
    domain: zha
    platform: device
    subtype: turn_on
    type: remote_button_short_press
  condition: []
  - data: {}
    entity_id: light.xxxxxx
    service: light.toggle

Through the same method you should be able to find your device_id. You can copy/paste the yaml into your own automation and go to town. Also, in the UI you can select the other actions on the button. Good luck!

Old thread, but for those still looking.
The E1524 is support and can be paired to ZHA (with some luck and randomness)
After being paired, button presses will trigger zha_event
You can ‘monitor’ these events via Develops Tools > EventS


I followed the steps to pair the 5 button remote with ZHA and I see the device created with just the one entity for power. I am not seeing any events coming through from the remote when I press any of the buttons (I am listening for events as described above). Any further tips on how to get the button presses to be recognized? I am using 2021.07 version of home assistant core.

@zraken Any luck getting the events to appear? I am facing the same issue. @DavidDeSloovere Any tips will be greatly appreciated!

Thanks in advance!

Nope, still no zha_event. I tried different firmware versions on my tasmota sonoff zigbee bridge as well as a HUSBZB-1.

1 Like

Hmmm! I also have a sonoff Zigbee dongle CC2531 connected to my RPi to manage my Zigbee. Could the sonoff hardware be the issue?

I suspect the zha integration is not handling the zigbee button press event. With zha debug enabled I see a debug message pop up on the log whenever I press a button but nothing happens after that.

Mine worked ONCE, just once. Then nothing. I suspect my Sonoff Zigbee dongle can’t handle the number of devices I have, or something similar. I tried reconnecting the remote with a new battery even. Something strange I noted: even a feet away from the TRADFRI repeater its connected to, the remote has very low LQI and unknown RSSI.

Hey Guys, i use the “Elelabs Zigbee Raspberry Pi Shield” and had the same problem.

This works for me:
Open the back of the tradfri remote, and press the button 4 times (the red light in front will blink for five seconds).

Now in Home Assistant: Scan for new devices (in my case with “Zigbee Coordinator” under “Devices”) and bring your remote close to your Raspi. Now press the button on the back of the remote 4 times and if nothing happen, press it again 4 times. Then the remote should appear in your HA Backend and you can add it.

I hope it will also work with other zigbee devices.
I created a few automations with different Buttons (e.g. toggle lights or open my garage).

I have been able to pair the device and it shows up as the IKEA remote under zigbee devices, the problem is that I’m not getting any event when listening to zha_event.

I have not used the tradfri remote in HA, because it wasn’t worth my time.
Just noticed it’s still in Home assistant, but no zha_events anymore.
The dimmer is linked to led panels in my kitchen; but I’m getting a new kitchen in a few weeks, so I don’t know what I’ll do with the dimmer…
The dimmer as a rotating dial would be great for some volume control, but then again, other remotes work better (or actually work). Like the 5 button ikea remote, via ZHA (this one doesn’t throw events, but can be used as Device in the trigger of an automation).

Thanks. TRADFRI Remote is the IKEA 5 button remote. It is their Zigbee brand name. You say it is not throwing events but can be used for automation. Can you explain how it can be done and how a button press can be captured?
Thanks in advance.

Trigger Type: Device = awesome

Thanks. The issue is, I don’t see any actions when I try automations using the TRADFRI remote. The actions dropdown is grayed out.