Person entity

I have added this to my config:

  - name: Matt
    id: Matt_User
      - device_tracker.matts_iphone

i have then followed these instructions to add a picture:

but when I click save it says “The following attributes weren’t set. Set them if you like.”

I think its the bit I am supposed to put in the attribute value thats wrong, I have just added a photos folder to my www folder and have entered the following in attribute value:

(the “x” are my ip address as far as I can tell)

guessing this is not right, but not sure why.

First of all, I recommend using the GUI for adding persons. You can edit the person device trackers without having to restart the system, and all from the GUI.

Secondly, you have “” (editing out your private IP address doesn’t really serve any purpose here), so do you have a VALID certificate for your 192 address? Or are you using duckdns or some other method to get certs and use a domain name?

I think you may be able to just specify /local/images/matt_user.png for the entity_picture attribute.

Thanks, I was going to use the gui option but it said it was note available in Yaml mode and I wasn’t sure how to not be in yaml mode or whether I really wanted to not be in that mode.

Good point on the certificates, I’m using duckdns to access it from work so maybe that. Should I switch to gui mode?

I don’t see where it says that at all.

You can add person: to your yaml and configure from the GUI.

If you use https, you need to have a valid certificate.

Ah I was trying to go to configure UI menu from the top right (shown here on phone)

Where should I be doing configuration using the gui?

hamburger menu, left hand side, CONFIGURATION, Persons

Configuring the UI and configuring the system are in different locations

Perfect got it all now I think. I deleted the details from my config and just added person.


Added a person using the config but it named it matt_2 which was annoying so now trying to delete both and start again.

It has flagged some odd device tracking behaviour which I’ve noticed before but ignored.

I have device tracking on my iPhone, I think using owntracks and whenever I restart HA my status goes to away, whether I was home or at work before hand and does not seem to update correctly for some time.

Me again!

A little bit confused, I now have “Matt” in the persons configuration, but in states in the developer tool bar I have person.matt_2 and person.matt

In my lovelaceui I have this:

    - type: entities
      title: Family
      show_header_toggle: false
        - entity: device_tracker.matts_iphone
          name: Matt xxx
        - entity: device_tracker.danielles_iphone_2
          name: Danielle

I renamed “Matt” to “Matt xxx” to see if that made a difference but it didnt, so not sure why I now have two people?
only one of them appears in entity registry?


Sorry, and another question. Now I have a person I still cannot work out how to add a photo, using the steps I tried to do above with configuration ui and assigning a picture to the entity_picture still does not work, so should I follow the documentation and add something like this to my config:

    entity_picture: "/local/ada.jpg"

Does that mean I have then used the GUI to add a person, but my config file to create the image, is that not odd?

If you add it via yaml, i’m pretty sure you need to restart. If you do it though the GUI, then you don’t. So are you restarting?
You may need to refresh the page and possibly wipe the cache. CTRL+F5 will do that.

Perfect thanks. A restart and browsing in incognito shows only one user.

It also let me add the picture using the GUI but when I go to my card now it doesn’t show the picture so obviously something wrong with using /local/images/matt_user.png but I’ll keep playing.

I am using duckdns so if I do need a longer file path how would I get that?

Just to close this issue off, using the GUI I added entity_picture and the path local/images/matt_user.PNG

When i pressed save in white at the bottom it said the following attributes were not set, but coming out of it and into my customize.yaml file it had added the details into there and the image works.

Had I had known that the GUI just added it into the customize.yaml I might have just put it there myself, but it works thats the main thing!



Hello all! I realize this is an older thread as I had the same question with regard to adding a photo. Allow me to clarify for those who are brand new to Home Assistant:

If using the path “local/images/you.jpg” did not work for you, enter the IP of your host:8123/local//you.jpg instead.



As per the documentation.

Edit: that was what worked for me, as simply entering “local/image/etc” got me nowhere. I’m unsure why that is, but I’ll figure it at a later time.:sunglasses: