Philips Hue changed to unavailable


My Philips hue bulbs several times a day change to “changed to unavailable” in the logs and then back to the setting they were at.
My hub has been moved all over the house and connected to 1 router upstairs and 1 downstairs, exactly the same issue. I have move it as far as away from the router as possible, same problem.

Anyone have a clue please?


I am assuming they are connected to a Hue Hub. Did you try changing the Zigbee channel? Perhaps there some other signal interfering with your installation.

they are and I have also switched channels several times… all very odd

for reference see All my hue lights randomly becoming unavailable

are you running processor heavy automations or python_scripts?
Have you checked your log for connect to the hue hub and thing errors?

thanks… I don’t really run anything that is processor intensive plus it is an Intel NUC.

i did turn on debug on the hue and I get this fairly regulary

2018-08-25 13:21:39 ERROR (MainThread) [homeassistant.components.light.hue] Unable to reach bridge
2018-08-25 13:21:41 INFO (MainThread) [homeassistant.components.light.hue] Reconnected to bridge

network is totally stable and have a ping test running to the hub and zero drop outs… very annoying

too bad indeed, and so annoying, yes. Glad you warn for this even on an intel Nuc, cause i would have almost tried upgrading the hardware for this (running on a Pi3 now).

somehow the Hue integration gets updatet in another frequency than the Hub likes, or vice versa.

right I have stripped everything out of my config so it is basically just the hue and zero automations or scripts. and it still happens. This is so damn annoying.

Any more ideas please anyone?


This has been happening to me too for the last few weeks.

I’ve just created a new Docker container without copying anything over from my old config, and only setup my Hue lights. So far so good for the last few days.

I’m now starting to add other things… gradually.

BTW, I'm also running HA on an Intel NUC (through Docker containers).
1 Like

Guess this would be a good time to chime @balloob in, and ask for further help.

I haven’t found a solution yet, and it only happens on the Hue integration ( as far as my setup is concerned).

You can’t just tag me and expect help. That’s rude. I have better things to do.

1 Like

keep me posted please? I’ve stripped mine down to the bare bones, but I guess the next step is a new container. It had been working totally fine and I hadn’t actually changed anything except update HA

Will do :+1:t3:

While I am not aware of mistreating you in any way, I feel sorry if I have misbehaved here. Not my intention at all.

The thing is I and many other community members are trying to solve the issues of Hue integration and flapping Hub/lights for several months now, an no solution seems to be imminent, or even to be recognized and acknowledged by the HA team.

I am not sure what else we could do other than every once in a while report or post about our/the (lack of) progress on this subject. I for one have posted, even on your own request, more than a few topics, and provided code and case descriptions, offering help in my limited skills. Haven’t heard since.

So, please forgive me for confirming another community member in his experience, pointing him to other posts on this forum.
I truly believed to do good to mention you, since you’d be in on the added info, and you are the expert per se.

I wasn’t rude, and don’t appreciate that judgmental attitude at all tbh. All doing our thing to help Homeassistant reach a perfect integration of one of the worlds industry leading products. I couldn’t imagine you wouldn’t want that.



I have similar issues with lights becoming randomly unavailable, hoping someone can look into this!

Same issue and on a NUC too. I deleted my Hue hub and then rediscovered it , paired and so far it has been robust

…some more info.

I’ve also tried doing a factory reset of the the Philips Hue hub. It works fine through the Philips Hue iOS app, and though any HomeKit app, so the only problems I was seeing was through Home Assistant.

Did this an hour ago… and all lights unavailable yet again… this is a joke

and it is now happening every 10 minutes.

Only now do I realize this is explicitly introduced and thus intended behavior…

have had issues with this ever since.

I had a few links for reference lined up: Any hope to get hue.hue_activate_scene back?

Btw, I thought to have it solved, (by disabling the CC and killing all my python scripts listening to the lights). It isnt though , lights are still showing unavailable at irregular and often times.

Unfortunately it is still very unstable.

We might want to raise the issue again on the Github… This newly introduced Catch should mark lights unavailable when the hub is, but as I can safely report, this happens even when the Hub is available just fine. Got 3 device_trackers to prove that :wink:


Like everyone else here, I’ve had this issue off and on for several months, I also have a device tracker for my hue hub, but…It could still be connected to the network, but not responding to “hue” commands, etc. At least I could see that possibility.

I do think you’ve found the “cause” though. Seems very plausible that the hub is not talking well with HA for a bit of time, and the bulbs are then being set to unavailable. That makes more sense. I’ve been troubleshooting this as a mesh issue, or a bulb issue, but sounds like a hub communication issue with HA. Any logs I could look at to see what the actually communication issue might be? Next time I happen to notice it I’ll make 100% sure I can still control the bulbs with my hue app. For me the flapping only lasts for short periods of time, so its not always easy to catch.