Philips Hue e27 change color with transition effect


I’m using Home Assistant OS newest version with CC2652RB on a RPI 2and Philips Hue e27 bulbs.
When I ask Siri to change the color or when I change the color from the Apple Home app, then it changes the color without any transition effect.

How can I enable color change with a smooth transition ?

I found this property in zigbee2mqtt
But how can I configure it, so it is applied for every light bulb with every command ?

Go to the list of supported devices and search for your device. You said Philips Hue E27 colored, so it could be a Philips 9290022166. On that page, you see the device specific configurations with transition being one of them.

Next, go to the configuration.yaml of Zigbee2MQTT , section devices:. Find your bulb’s device and add transition: 2 for a 2sec transition.


    friendly_name: 'Colored Hue Living Room'
    transition: 2

Restart Zigbee2MQTT afterwards.

Sorry, I did not ask correctly. Where do I have to write this config down ?

File configuration.yaml of your Zigbee2mqtt installation (not configuration.yaml of Home Assistant).

I saw this in the config tab of zigbee2mqtt:

data_path: /share/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml

And I installed FileEditor, but I can’t see any other folder than “config/”

Then it is in devices.yaml.

I was not able to navigate to root in FileEditor.
After setting enforce_basepath: false in the config tab of FileEditor, I was able to navigate to root and then to /share/zigbee2mqtt and edit the devices.yml file.

And now transition works fine
Thank you @m0wlheld!

1 Like