Philips HUE Smart Button - 5 press actions + hold-to-dim

Great :slight_smile: no worries

1 Like

Hi @TheHolyRoger , thanks for all the amazing work you’ve put into this. I’m trying to get the blueprint to work in my first configuration, please bear with me as I am a novice with Home Assistant and started transitioning only yesterday.


alias: Hue smart button
description: ""
use_blueprint:
  path: TheHolyRoger/Philips_HUE_SmartButton.yaml
  input:
    scene_first_release: scene.relaxed
    button_toggle_dim_entity_first_press: true
    action_button_short_release:
      - service: light.turn_on
        metadata: {}
        data:
          brightness_pct: 50
        target:
          device_id: 68fa0c1846d223c6705b38af9d2dfcd5
    helper_multi_press_delay: 2000
    resume_light_state_when_off: false
    helper_last_controller_event: Hue smart button
    controller_topic: zigbee2mqtt/0x001788010802cad7/action
    hold_to_dim_entity: light.0x00178801064e21fd

I can see see the controller topic coming through in the logs of zigbee2mqtt, and even when I monitor the automation table, it seems the last run status is reset on a button press.

The scene I defined is simple as it turns on a single light “Maan lamp” to a set brightness and colour.

I did update HA to 2024-01 this morning.


Core
2024.1.6
Supervisor
2024.01.1
Operating System
Frontend
20240104.0


Friendly name
0x001788010802cad7
Description
Last seen
N/A
Availability
Disabled
Device type
EndDevice
Zigbee Model
ROM001
Zigbee Manufacturer
Signify Netherlands B.V.
Description
Hue smart button
Support status
Supported
IEEE Address
0x001788010802cad7
Network address
0x5A2E
Firmware build date
20210528
Firmware version
2.47.8_h2F968624
Manufacturer
Philips
Model
8718699693985
Power
Battery 59.5%
Interview completed
True

Hope you have any guidance!

Update: turns out when I define (ADVANCED) Button initial press, I am able to invoke some reaction from the lamp. Anything above from (OPTIONAL) doesn’t.

Update 2: Turned out I didn’t define a text helper, i figured it was only a custom name in the blueprint. I believe it is working now… TY!

Forgive my ignorance, is there a way of making the dimming transition effect more smooth? It goes instantly from one level to the next.

Glad you got it working :slight_smile:

Try changing the (ADVANCED) Transition time for light on/off option - it should be renamed as it affects dimming too

1 Like

Good morning,

I would like to use this Blueprint, but there is something in the configuration that I don’t understand!

If anyone had an idea, solution to help me understand? With an example. I’ll take it.

What I don’t understand in the configuration:

“Make sure you create a text helper with a limit of at least 500 characters. » ?

My hue buttons are:
Smart button
Hue Dimmer switch v2 (button Hue)
wall switch modules

I use Zigbee2MQTT and not the Nabu_Casa_SkyConnect even though I have this dongle.

I added this below:

Then

But when I press the button nothing happens, the button reacts but the bulb does not light up.

Is there a video that will show you how to use/configure this bleuprint? I would like to use it but I don’t understand everything to do!? Thank you.

First, thank you @TheHolyRoger for your impressive blueprint which has made moving away from the Hue integration much smoother. I just have one small request concerning the dimming/brightening - is it possible to have the dim/brighten steps transition more smoothly?

For my bulbs the steps come in quite “jagged” rather than a smooth transition between steps and changing the transition “(ADVANCED) Transition time for light on/off” doesn’t seem to smooth it out. While I can change the step size “(ADVANCED) Dimming Brightness Step” I find that even a value like 10 is still noticeably jagged albeit smaller, but it makes it terribly slow to adjust. I think the original Hue behaviour was a smooth transition through dim/brighten and it would be nice to reach that again with zha if possible.

Thanks again, and apologies if I’m missing something silly!

In this screenshot here your text limit is only 100 chars but you need to set it to 500

I’m still kind of working out the kinks here myself :slight_smile:

I’ve found the zha integration to be really hit and miss to be honest, I still use the hue integration for a lot of my hue lights. The native hue bridge seems to link lights directly with each other where as zha etc do not… When you change lights that are in groups via the hue bridge they’ve optimised the way the commands are sent to each light relaying from each other, which is not the case with zha.

My advice is to first try and tweak your settings if possible to make brightness commands work smoother without using the button first. There’s different brightness commands in HA that behave differently with light groups. Try the different ones there and let me know what works best/smoothest, then I can try and change my blueprint.

brightness_step_pct which is what I think I’m using right now seems to be the worst in terms of smoothing

Hi,

How can I customize the blueprint to use it with hue dimmer switch ?

Yes, exactly. When you add a light to the initial button press you see all of the light options, such as transitions and colors, etc. But when you want to use the toggle option, you’re limited to just the couple of options in your blueprint. I use the initial button press to toggle since I mentioned this, with all of the options desired. It was just a little confusing to me initially. It would be nice if you offered all of the light options in the blueprint when a user chooses the toggle option. Also what I thought was confusing is how the first button press is at the bottom of the button presses (after quintupple) instead of first, then first press release, then double, triple, etc…

Not meaning to sound gripey or unappreciative, I’m still using it and I’ve learned a lot since I first mentioned this. I’m glad you made it and I’m glad I found it and figured out how to use it. I’m just pointing out some things that could clear up some confusion for other users and help them get their desired result a bit quicker.

Sorry for the long delay in response. I actually forgot about this and I guess I had my email notifications turned off (they’re on again now).

No worries, I get what you mean, the blueprint does need tidying up quite a bit so I’ll look at the bits you mentioned :slight_smile:

I haven’t played with blueprints in a bunch of HA versions so hopefully there’s some new things I can incorporate…

I can definitely add options to change the “turn on” command in the toggle option so will do that too

Hi.
I have installed this blueprint and tried to configure but the automation does nothing.
Here is my code:

- id: '1713811189863'
  alias: HUE Smart Button
  description: ''
  use_blueprint:
    path: TheHolyRoger/Philips_HUE_SmartButton.yaml
    input:
      controller_topic: sensor.0x0017880106072658_action
      helper_last_controller_event: input_text.helper_last_controller_event_s
      hold_to_dim_entity: light.0x0017880103c7f08a
      button_hold_to_dim: false
      button_multi_press_enabled: false

I use Zigbee2mqtt.

Thanks for this I have got it working. Question to throw out there what would be the best advice to be able to use this with a motion sensor. i.e. motion sensor triggers the lights on but can be overridden by using the switch?

Hi @TheHolyRoger, nice work about this blueprint.

I integrate a first button with it, and I faced with the case that dimming then release the button shuts down the light. (Philips HUE Smart Button - 5 press actions + hold-to-dim - #104 by TheHolyRoger)

Was this case fixed ?

I picked the linked version on top post.

Hi, I plan to do the same thing and I think that the best approach is to abort the motion sensor scenario if there is a manual trigger since an arbitrary period (eg 20 min). To handle that, I guess I’ll read the blueprint text helper last_triggered date value.