Philips who? (false-positive & discovery ignore/blacklist doesn't work)

How bizarre, I know there have been a lot of changes to the way discovery works in HA since v0.94 onwards, so this may be a bug, HA could be seeing something and wrongly assuming it’s a hue device.

If you feel brave you may be able to sniff packets with wireshark but this is far from straightforward.

Are you trolling everyone? I can’t tell. Either way, you’re being annoying. As annoying as your phillips who issue.

Also, I literally spent 2 minutes searching the esperna docs and found out how to turn off discovery. Heres a direct link to it.

haEnabled MQTT Discovery 0 (no) or 1 (yes) 1 (yes)

Also, seeing that you aren’t being straight forward with anyone, have you placed the following code into your configuration?

    - philips_hue

Hey @petro,

did you mind spending 5 minutes reading the thread beside waisting 2 minutes for searching and providing totally useless advises here?

The mqtt ha (is for home assistant!) discovery you mentioned has literlly nothing to do with a (emulated) Philips hue integration.

Also it’s even written few posts up that discovery ignore for Philips hue is broken (actually it doesn’t use the discovery component anymore but zeroconf or ssdp - both don’t have a ignore implemented)

In all I wonder WHO is trolling actually…

just comment out ssdp in your configuration.yaml if your not using

  • Deconz
  • Philips Hue

I don’t have any ssdp in my configuration.yaml. Guess the thingie is discovered with zeroconf then? Any possibility do disable this without collateral damage?

@petro nice trolling :joy:

1 Like

Emulated hue has nothing to do with discovery. That’s the thing that you’re all missing. Emulated hue is configured in home assistant and not automatically discovered. So I have no fucking clue what you’re even going on about.

1 Like

do you have default_config in your config?

yes sir (post must be at least 10 characters)

@Petro do you know more? Want to share your knowledge with us (and not repeat what’s in this thread already)?

1 Like

default_config loads a lot of components by default including ssdp lists the ones it loads

so if you want to remove any of them from automatically loading, you need to remove default_config and add all the components back you require


I’m only repeating what’s in the thread because your responses are ambiguous. I honestly can’t tell if you’re trolling or not. Give a straight answer and you’ll get straight answers. Yes, I’m being serous. Although this morning it seems you’re taking this a little more seriously.


Thank’s @aidbish

Is there any chance that this is discovered by ssdp rather than zeroconf? I can disable zeroconf the same way (and loosing probably almost all discovery functionalities?) or maybe even more?

if its the espurna(which i suspect it is) i have just tested it and enabling ssdp the espuran device came up in HA as a philips hue, removed SSDP and its gone

read bottom of this page about whats ssdp discovers


i think it espuran using the alexa integration that exposes it as Philips hue
Espurna uses this library for alexa support which confims it exposes them as Philips HUE

just tested this and it works

go into each espurna device you have
goto general, then right at the bottom of that page turn off alexa integration
reboot espurna

restart HA

1 Like

Thank’s for your investigations! But I have the alexa integration since always disabled on my espurna nodes :thinking:

You had ssdp enabled in your last run (and just disabled alexa integration in espurna) and got rid of the permanent discovery notification in home assistant?

yeah i have re-enabled ssdp and disabled alexa in espurna and no more notifications

maybe just check its still disabled in th e espurna

1 Like

Thank’s @aidbish you put me on the right path!

After fiddling around with one espurna node which behaved weird (didn’t proper update the sensor data via mqtt and the web interface of the node failed often) I found this one to be the cause of everything. Even though the alexa integration was disabled all time this mentioned espurna node did behave wrong (properly causing home assistant to discover it as Philip). A single restart of the node mcu did help but doing a full power cycle with unplugging the power source recovered the espurna thingie back to normal. One more restart of home assistant and finally the permanent notification is gone (for now)! :partying_face:

1 Like