Physical switch toggle state not registering in Home Assistant

I have several Innovelli NZW30 switches.

I’m not sure when it started happening other than it was recently and around the time I updated to .98 or .99 but none of them are registering a state change in HASS when using the physical toggle. The lights work so the physical toggle isn’t disabled.

I was going to chalk this up to something gimpy with a particular switch but it’s happening to ALL of them. It looks like something in the ZWave stack isn’t sending the switch state as I’ve confirmed in the ZWave log that there are no events when the problem switches are physically toggled.

Toggling it at the Lovelace interface works as normal and also registers events in the ZWave log.

I’ve sent a note to Inovelli support but I wanted to see if anyone else in the community has run into this before? It seems unlikely that there’s something wrong with ALL the switches but it also doesn’t seem like a HASS thing. Maybe an OpenZWave library thing?

Anyone else out there with the NZW30S and .99.x that can test to see if they are seeing this behaviour as well?

I’ve tried a few things with Inovelli support with no success.

So I’ve tried excludes and includes, both secure and insecure. But no dice. I’ve also tried completely removing all my HASSIO containers and re-installing from scratch (with existing config).

Eric at Inovelli has tested with .98 and and upgrade to .99 and hasn’t been able to reproduce.

Anyone have any other suggestions about where things could be failing before I try completely blowing away my ZWave config, reset my stick and rebuild the network from scratch?
Either the switches (five Inovelli switches in total) have suddenly stopped sending ZWave events on physical toggles (including scene events) or something in the hassio zWave stack isn’t seeing them or processing them.

So I finally resolved this by excluding the switches, killing the mains to them for ten seconds or so and then re-including. Physical toggle now generates a z-wave event.