Pi 3b+ install via lte cellular rtr problem

Hi all,

I’m attempting my first HA install, and my internet connection is via a Netgear Nighthawk M2 lte hotspot. It’s on the Optus cellular network and does NOT have a static IP (almost impossible to get static IP for cellular services in Australia).

I’m pretty illiterate when it comes to networking and coding.

The HA install progresses well, until the “HOME ASSISTANT” welcome shows up on the connected hdmi monitor.

I cannot connect to the home assistant control panel via a laptop browser connected by WIFI to the Netgear M2 network the specific address or the general address. It says connection timed out, reset, or rejected (or something similar)

The Pi 3b+ is hard wired to the netgear M2.

I assume I need to connect via the browser to set up account and continue installation?

Is the problem that the wifi hotspot doesn’t have static IP?

Are there any other ways I can install with only the Nighthawk M2 as my internet connection/router?


You system does not pickup a DHCP address. Check your connection to the router, most likely cable issue.

1 Like

If it didn’t pick up a DHCP lease, the Pi wouldn’t have any internet access at all and HAOS would not have been able to install and setup itself.

Nope. No need for a static WAN address.

What do you mean by this ?

Tested cable, and tried an alternative. All good there

Hi Alex,

I mean the Pi ip address and the local home assistant addresses. http://you-ip-address:8123

I enter these in the web browser of my laptop that is on the same network (via wifi) and I can’t connect to complete setup

Your Pi is connected by cable, your PC over wifi through your LTE router ? Are you sure both are on the same subnet and there is no firewall on the router preventing both to connect to each other ? Can you connect your PC over cable too ? Ideally by using an external router / switch (put both the Pi and your PC on the external switch and plug that switch into your LTE router).

What’s the local IP address assigned to the Pi ? Most likely starting with 192 or 10, don’t worry, these are not public IPs but LAN IPs, noone can connect to these from the outside, they’re local to your own network.

1 Like

I’ll have to google that and work out the subnet and firewall stuff. No idea how that works.

I did turn firewall off on the laptop, didn’t think there might be one on router

I also tried two different Pi machines, with different IPs

I may be able to borrow a small switch and try that way!


I managed to install HA using my Android phone hotspot and logging into Home Assistant app.

Now I just have to connect home assistant to my cellular router that hosts my automation network. (in a motorhome)

I assume I can just log onto the wifi connection and then add my devices and sensors to home assistant?

Is it something silly like the router having a “wireless isolation” feature?

Where devices connected to the WiFi side can’t see each other on the LAN?

I’ve had issues like this before, so when I see “wireless isolation”, I turn it off. (Unless I have a specific reason not to)

1 Like