Pi 4 setup with Razberry V2 (Solved)


Im completely new to Home Assistant. I’m trying to switch from Domoticz. I bought a Pi 4 and want to use my Razberry v2 for my Z-wave network. I adressed it to /dev/ttyAMA0. When I start the network nothing happens.

My OZW log:

2020-01-06 12:59:39.790 Always, OpenZwave Version 1.4.3452 Starting Up
2020-01-06 12:59:57.276 Info, Setting Up Provided Network Key for Secure Communications
2020-01-06 12:59:57.277 Info, mgr,     Added driver for controller /dev/ttyAMA0
2020-01-06 12:59:57.278 Info,   Opening controller /dev/ttyAMA0
2020-01-06 12:59:57.278 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2020-01-06 12:59:57.278 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2020-01-06 12:59:57.279 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2020-01-06 12:59:57.279 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2020-01-06 12:59:57.279 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2020-01-06 12:59:57.279 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2020-01-06 12:59:57.279 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2020-01-06 12:59:57.279 Detail,
2020-01-06 12:59:57.280 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2020-01-06 12:59:57.280 Detail, contrlr, Notification: DriverFailed

Don’t know about Razberry, but this topic might help you solve your problem:

Thanks! But that doesn’t work for me. After editing the config file HA won’t start. Anyone else running Pi4 and Razberry with success?

Hi! I found a way of doing this. I followed a guide from a swedish store. The guide is för Pi 3 but it worked with the Pi 4. I just replaced every string containing pi3 with pi4. I then adressed the Razberry to /dev/ttyS0. If it’s right or wrong I dont know, but my network is up and running!



I ran into the same issue. I migrated from rpi3 hassio to rpi4 hassio in docker on raspbian with raZberry card.
The key was to disable bluetooth and enable serial interface:


inside /boot/config.txt.


THANK YOU!. pettertho there is so much outdated info on this. I knew it had to be something simple to get the Razberry hat to work at this point. The Documentation for the Razberry board needs to be updated on the main site.

1 Like

Hello guys,

I’ve found a way to make the Raspberry Pi 4 work with the RazBerry V2 (blue).

  1. After you burn the HassIO img onto the SD card, you need to go to config.txt file and add:
  2. Power on the RPi 4 WITHOUT the Razberry module.
  3. After the installation is complete you can put the Razberry module back on the GPIO.
  4. Go to the Supervisor and install the ,File Editor" addon.
  5. In the File Editor add the following lines:
    usb_path: /dev/ttyS0
  6. Go to Configuration -> Integrations -> Choose Z-Wave -> Use the following line for the USB path: /dev/ttyAMA0
  7. Go to Z-Wave and choose Start Network. The RazBerry 2 module should light up green and let you add devices, heal network and all the other things.

Hope my message find you well and will let you successfully configure your RPi 4 to be used as a Z-Wave controller.


I have an established install On a Pi 4.

Can I make the changes to the config file of the current active install or does it have to be as part of a clean install?

@cedy22, unfortunately that didn’t work for me on a new manual python install. I’m new to Home Assistant and have been struggling for this on and off for a few months ever since Wink decided they were going to charge for their previously free service. They just kicked in the freemium version a few days ago with reduced capabilities, so I’ve been trying to finish up the HA setup with zwave.

I am using a manual python install from raspbian lite because I want to run other things in the background on this Pi (pihole, other chron jobs, etc), so the File Editor isn’t available. I replaced that step with modifying the configuration.yaml file, but no dice.

I have invested enough time on this now, so I’m about to swap my Raspberry Pi 3 I’m using for a 3D printer with this one. If more documentation does come around with an honest fix I’d be very interested. I’d rather have my Pi 4 running HA.

I tried follow your steps and it all went fine until step 6. When I went to integrations, Z-Wave had already popup, and then I got a notification that the USB path was not found
“Component error: usb_path - Integration ‘usb_path’ not found.”

I tried change to /dev/ttyAMA0 in the config-file, but no luck.

Worth to mention is that I have the older version of Razberry expansion card attached to my RPI4.

I will update in this thread if I get it working.

If anyone has any tips meanwhile, please feel free to advice! :slight_smile:

So I got it working, the error was a really n00b-fault.

I had missed the two blank spaces in the config file before the usb_path: /dev/ttyAMA0 line


  usb_path: /dev/ttyAMA0


So now I’m up and running razberry older version on rpi4 :heart_eyes:

Noob rpi question, when you add a hardware module, do you need to shut down first before booting up with the card attached?

Yes, I would not recommend to connect or disconnect any hardware with power on.

It is kind of an usb port, but I wouldnt take the risk of damage.

At point 5: in which file should I add the lines?
" zwave:
usb_path: /dev/ttyS0"

Note: I want to use the Enocean Pi Module (element14).