Pi_hole.disable not there anymore butintegration is ok?

I used to be able to use service “pi_hole.disable”, but tha tis not there and when pressed in lovelace I get an arror it is not there…

My integration is ok:

Can’t see in developertools:

Where is my service gone?

There was a breaking change with Pi Hole in the 0.114.0 release see here. You need to configure an API key and then you’ll have a switch for each pi hole instance.

Indeed :slight_smile: - breaking…

but do I need to delete the integration? and re-add thats not stated somewhere?

I added my api in config.yaml… restart homeassistant… but still no service?

Did you try removing the lines from YAML, restart and configure it through the UI or adding the lines in YAML again and restart?

when I remove yaml, integration stays in…

Then remove yaml, delete integration, restart, add ibtegration throug UI.

Yes, that works. service is back now…

but I cannot call it anymore… I need an example of the

pi_hole.disable options… it says (did never):

need to do:

but don’t know how…


entity_id: all

solved it… can put my piholes to rest with 1 button now (2 piholes).

Question is for how log because I am charmed and have 1 running now: adguard…