Pi-Hole with Nabu Casa

Failed Host Check: blah.ui.nabu.casa vs 10.0.20.253, , nunya-pi-hole.local.hass.io, pi.hole, localhost, hassio, hassio.local

Pi-Hole just updated the app to work with Hassio Ingress, and in theory should work with the Nabu Casa remote service.

I get the above error instead.

I’m having this trouble as well.

Add your nabucasa URL in the virtual_host key of your config

Where and in what format would that go?

In the config for the addon there’s a virtual_host key, the value of that key should be your .nabu.casa URL

ah, thank you!

It worked! As a note, don’t include the HTTPS portion, just the URL.

Thanks, this worked for me too.
Any idea how my yaml should look for the Pi-hole Sensor?

I’ve got it like below but it doesn’t seem to work:

#===================
#=== pi hole sensor
#===================
  - platform: pi_hole
    host: xxxxxxxxx.ui.nabu.casa
    monitored_conditions:
      - ads_blocked_today
      - ads_percentage_today
      - dns_queries_today
      - domains_being_blocked
      - queries_cached
      - queries_forwarded
      - unique_clients
      - unique_domains

and my pi-hole add-on config :slight_smile:

{
  "update_lists_on_start": false,
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "interface": "",
  "ipv6": false,
  "ipv4_address": "",
  "ipv6_address": "",
  "virtual_host": "xxxxxxxxx.ui.nabu.casa",
  "hosts": []
}

this gives the state “unavailable” to all pi-hole sensors.

thanks in advance!