Pi4+SSD too much to handle for powersupply? replace with

having a few unresponsive states of my Pi4 lately, (not able to connect remote or locally, no SSH, no nothing really…) I can only bring it back to live pulling the cord and back again.

Had never experienced that before, until (it only dawned on me later) I changed architecture and use the SSD to run the system on now .
Although I have never seen the power supply integration return a warning or error, I guess it is not capable of powering the 2 together?

So, I am asking some advice from the community, what supply I would need, and how to proceed? there’s only 1 connection on the SSD, so how to add that to a usb power supply, and still connect it to the Pi4?

Please have a look, thanks!

Perhaps an external usb hub.

There are USB to SATA cables which have two USB A connectors. One is for data and power while the second is power only. With one of these and another USB PS into which you plug the second connector, the SSD will gave plenty of juice.

just be sure: the external PS would be only for the SSD, and not for the Pi4 would it, id keep the original Raspberry PS for that?

Power supplies do vary a fair bit in quality and power output, you want one which can reliably put out at least 3 Amps. I’d recommend getting the official Pi 4 USB-C power supply as I’ve never had any problems powering a Pi 4 and a connected M2 SSD in USB3 enclosure or 2.5" SSD with a USB3 adaptor using one. Currently have my HA setup on a Pi 4 with the latter setup along with a USB Zigbee dongle and the official Pi 4 PS is providing more than enough power.

hmm, I am using the official Raspberry PS… are you saying that should be sufficient? or is the

the power supply for the SSD, sorry if I misunderstand you here.

The power supply is only plugged into the Pi. If you are using the official one it should be fine for your setup unless you happen to have a particularly power hungry SSD. (I assume it is the latest version of the official PS with the USB C plug rather than the older version which has a micro-usb connector and has a lower power output)

I fear I have the micro-usb, and the box states 2.5A, 5.1V …

Ah, that may well be it then. I’d recommend upgrading that first rather than trying to go down the route of y-cables for powering the SSD as it keeps the setup a lot simpler for diagnosing future problems etc.

yeah, Id love that too, but how to upgrade it, while the newer versions have the usb-c connector… use a converter plug for that?

Sorry, I mean just buy the newer USB-C version of the official RPi power supply and use that to power your Pi 4 instead. You should not need to use a converter plug, not sure which country you are in but there should be a local version of the one I linked from your local Raspberry Pi supplier or Amazon etc.

So sorry, I miss remembered… using the 3A usb-c version after all…. duh.

the box I mentioned ws from one of my other Pi’s. sorry again.

My SSD is T3, 250GBmodel MU-PT250B, and it states ‘rated +5v 0.7A’

No problem, looks like the SSD is on the more power hungry side as mentioned above after all. Sounds like Frank’s original suggestion is going to be your best bet.

I’ve found this site a good resource on which combinations are known to work and what sort of performance to expect:


thanks! mine is bottom of the list… still, it is on the list :wink:

searching for an adapter to power the SSD then, its not very obvious where to look. see Raspberry Pi 4 Bootloader USB Mass Storage Boot Guide for example, what on earth am I looking for, Franks suggestion isn’t in that list?

there’s this explicitly mentioning a 3.5A PS…

Verify Power Supply Size (3.5A strongly recommended)

Check your Raspberry Pi’s power supply size and make sure it is delivering at least 3.5A. There are a lot of USB C adapters for the Raspberry Pi that are only 3.0A. These will typically work fine, until you plug in something like a SSD which draws power from the Pi and there is nothing left to give.

Most SSDs are quite power efficient but HDDs draw significantly more. Older generations of SSDs used quite a bit more power than newer ones as well. If you are using an older drive or a drive that you know is power hungry you need to pay extra attention to having a quality power source with plenty of capacity.

A good alternative option to relying on the Pi to power the drive is using a powered USB hub* so your drive doesn’t need to draw power from the Pi’s limited power budget. Make sure you get one that is compatible with the Pi as some powered USB hubs won’t work properly with it so check the reviews and do your research to make sure people are using it successfully with the Pi.

Using a 3.5A power supply* or powered USB hub* will ensure your drive is getting enough power without impacting the Pi’s stability.

Didn’t notice the link I gave included your solution. Looks like Sabrent Powered USB 3.0 Hub they’ve linked to and recommend may the answer to your problem.

The 3.5A PS would be a great alternative too as long as you can get one, think the Canakit one they mention is not available everywhere.

Guess I am completely missing the obvious, but, using the the powered USB Hub, how do I connect the SSD both to the Hub, and the Pi4…?

You’d power the Pi 4 with the current supply as you do now, plug the hub into one of the Pi’s USB 3.0 ports and plug the SSD into the hub. The PS that the hub should come with provides power only to the hub and the SSD you have plugged into it. You have two power supplies plugged in but one powers the Pi directly and the second powers the hub and any other external devices plugged into it (i.e. the SSD).

Not the neatest of solutions but makes sure everything has adequate power.

1 Like

Al right! Yes, I wás missing the obvious :wink: thanks, problem solved.

I guess Nick, Frank and you all deserve the Solved tick, but I’ll enter it under your post with the link to that website because it holds so much info we didn’t yet have here.

Thank you all

Btw, the power status sensor integration still says all is fine, while I just experienced another blackout…
Could it be something else than a power issue ?

now I see this… blindly ordered the advised power USB hub, but apparently is suffers

BUT, if you’re going to use this on a Raspberry Pi (Pi 4 in my case), be warned that it exhibits the back-power issue whereby if you reboot the Pi, it won’t boot up again until you either remove the power adapter from the hub, or unplug it from the Pi.

now what, how to tell if this is true (I know, just try it…) and if another hub wont suffer this… I hadn’t seen it (back-power) being mentioned yet

yep, its true:
powered usb hub arrived today, and it seems to work. needed a second boot, but after that all went well. takes a bit longer to startup I feel. not sure yet. However, I seem to be bothered by the so called back-power… updating the OS to rc3 requires a reboot which isn’t performed until I turn-off power completely, and back on. Hardly a fine situation…

learned that we can either cut the power thread in the usb cable between the Pi and the hub (since the Hub has its own PS), or throw in another (bus powered) hub, which obviously doesnt transport the power… we’ll see :wink:

Nope… no success, can NOT reboot the host, not even with a tweaked USB cable with cut Red power wire. I have transposed this issue to #dev_os on Discord because it really is quite impossible to use the officially supported partition install, with regular/official power supply. Only rescue might be a 3.5+A PS, but they are hard to find. So a list of proven devices might do well in the community/documentation