Pick Server port not showing

I have installed several times ESPhome, but I cannot pick the server port. I have two USB serial ports which work with Tasmona or Arduino, but I do not know how to do it with ESPhome. Below is what I get and I cannot find the option. Any suggestions on what I am doing wrong?
RPI3b+,

Connect your device to the USB port then click this:

54745ceed98ca4ad718351b9e2c53971e38f47ab_2_690x388

You shouldn’t need to restart the addon after connecting the device but if the serial port is still not visible try that.

When I click on it I get Update all, secrets editor and logout

An from the second tab I get, clean MQTT, clean build files, and delete which I have done several times as well. Is there any other menus or a configuration file?

Yeah sorry it has changed. It should now be a drop-down list next to those top three dots. See the second picture here: https://esphome.io/guides/getting_started_hassio.html

There’s more help here: https://esphome.io/guides/faq.html#i-can-t-get-flashing-over-usb-to-work

Espflasher worked!

Tom, thanks for your help