Picture elements card not loading from the cloud

I hope I put this in the correct place. I didn’t find anything posted about this, so hopefully we are not re-hashing it.

I have a picture elements card for my floor plan and I cant seem to get it to load when connecting from the cloud. I have tried different browser / device with no luck. I am using the official cloud service Nabu Casa. If I connect from within the home all works as expected.

With the crome browser on my phone I can get it to load if I first connect from in the home and then switch to the cloud. This works till the cache is cleared.

With the official Android app it will not load at all.

Any insight is greatly appreciated! Thank you in advance!

Sam

1 Like

can you share your picture elements card code?
Especially the path to the picture…

lolouk44,

Thank you! The path was the problem! When I first set this up I was having problems getting it to work so I put the full path in (it works locally) and forgot to change it back!

        image: 'http://192.168.1.100:8123/local/MainFloor.png'
        type: picture-elements

Now I have this and it WORKS!!!

        image: '/local/MainFloor.png'
        type: picture-elements

Thank You! I just needed a bump in the right direction.

Sam

6 Likes

So I’m unable to get my 3D image Dark.png to load using either method. Is there a file size limitation?

Disregard, I finally figured it out through trial & error (though I don’t understand it).

The physical path is ‘http://192.168.1.79:8123/config/www/images/3DFloorplan/Dark.png’, which would not work. Tried ‘/local/www/images/3DFloorplan/Dark.png’ - did not work. Tried ‘/local/3DFloorplan/Dark.png’ - did not work. Tried ‘/local/Dark.png’ - did not work.

What DID finally work is ‘local/images/3DFloorplan/Dark.png’. Best I can determine is that upon creating the www folder and restarting, it becomes “local” and everything nests below it. Very confusing, but working. Only wasted 2 days trying to figure this one out.

Side note: Would be plus if the designers & experts applied just a little more syntax instruction in the documentation (for a lot of HA). Would really help more of us novices from burning up the forum looking for help and lend itself to more productivity. Love HA, but struggle on the syntax elements.

2 Likes