Picture of www folder is not updating

maybe there is already a solution but I couldn’t find one.
I have some pictures in my www folder that I’m using for a floorplan. Now I wanted to update one of the pictures and replaced it in the www folder with the new one.
But if I look at the floorplan it still shows the old one.
I’ve already restarted HA or used the image in an other view but it does not change.
If I give the new image a new name it works but I clearly don’t want to give every image a new name.
Hope you can help me.

Clear your web browser cache. Press Ctrl+F5 when looking at your floorplan.

Already did that. I also tried with another Browser

F5 won’t do anything.

HA uses aggressive caching.

You need to clear your browser cache in browser settings. Look in Privacy or Cache or whatever in the browser you are using.

Browser cache is #1 nemesis for web server (which HA uses - Apache) provided assets. It’s a nightmare - and is not limited just to HA. Any web server is the same.

In Chrome you can press F12 and disable the cache - helps when testing - then you can press F5.

Ctrl + F5 has always worked for me in Firefox. Ctrl + Shift + R also works for most browsers.

Then you have not got the same problem then.

Sounds like you’re only pressing F5. Read what I wrote carefully.

In the past Ctrl + F5 or Ctrl + R has worked for me too but clearing the browser cache solved it. Thanks

Nope. I know a little bit about the topic. I’ve coded many a web page since 2005 when I started dev work on apache…
Anyway, end of.