Home Assistant Community

Pilight Add-on

hassio-addon
Tags: #<Tag:0x00007fcf4a0da2e8>
#1

Has anyone gotten pilight working on Hass.io. I have found an add-on which is a pilight server which I assume you could then use with the pilight component but I haven’t been able to get this working. Has anyone had any experience setting this up? Thanks!

#2

I’m in the same boat. I had it running on hassbian but with hass.io I’m at a loss what to do. Did you solve your problem?

#3

I did but you would have to be willing to play around with docker containers and risk messing up your system. If your careful though, you will most likely be fine. See this reply I made on Github on how I got it working, https://github.com/pschmitt/hassio-addons/issues/25#issuecomment-491631671.

This is what I put in the configuration.yaml:

pilight:
  port: 5003

switch:
  - platform: pilight
    switches:
      heater:
        on_code:
          protocol: raw
          code: "867 502 408 510 400 498 410 501 866 502 404 508 405 499 865 499"
        off_code:
          protocol: raw
          code: "871 509 406 510 413 502 417 503 874 505 413 505 872 505"

And this is what I put in the Pilight config.json:

{
        "devices": {},
        "rules": {},
        "gui": {},
        "settings": {
                "port": 5003,
                "log-level": 6,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "webserver-enable": 1,
                "webserver-root": "/usr/local/share/pilight/webgui",
                "webserver-http-port": 5001,
                "webserver-cache": 1,
                "gpio-platform": "raspberrypi3"
        },
        "hardware": {
                "433gpio": {
                        "sender": 0,
                        "receiver": 1
                }
        },
        "registry": {
                "pilight": {
                        "version": {
                                "current": "8.0.2"
                        }
                }
        }
}

I can now raw send codes just like I used to on Hassbian but without Hassbian’s issues! The only reason I was holding myself back from Hass.io, was because of pilight, but now that I have it working, I won’t go back.

1 Like
#4

This is really helpful. Thank you!

I’m new to this whole thing with docker containers, but if I might ask before I try something that is doomed to fail. Would it be much more difficult to compile pilight in the container instead?

On hassbian I made the the changes for PULSE_LENGHT for the protocol that I’m using to lessen the load on the pilight daemon, but that required compiling it. Do you foresee any problems going that route instead?

#5

I honestly have only just started using docker containers as well so I wouldn’t want to spread inaccurate information but I’m sure that if you can install the commands to compile it with apt-get you should be able to do what you want to do in the console of the container. As long as your messing around with your pilight container and not any other addons or Hass.io images or whatever I highly doubt anything would happen to the rest of the system. I mean that’s why it’s called a container :laughing: Just make sure that you save/commit your changes to a new image or the existing one straight after doing that because if you restart or stop it will revert back to the old version. Another option could be adding the commands for compiling in the Dockerfile then building the image again. Hopefully you can get this working. :smiley: