Pilight stopped working after 0.43.2 update

My setup was working perfectly but then I updated RPi3 and HASS, and now, pilight is not working anymore.

I get the following error in HASS log:

17-04-28 21:25:59 ERROR (Thread-1) [homeassistant.components.pilight] Unable to connect to 192.168.0.11 on port 5000: [Errno 111] Connection refused
17-04-28 21:25:59 ERROR (MainThread) [homeassistant.setup] Setup failed for pilight: Component failed to initialize.
17-04-28 21:26:00 ERROR (MainThread) [homeassistant.setup] Unable to setup dependencies of switch.pilight. Setup failed for dependencies: pilight
17-04-28 21:26:00 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform switch.pilight: Could not setup all dependencies.

It seems that updating RPi3 (sudo apt-get update and sudo apt-get upgrade broke pilight). In pilight log I get the following message:

[Apr 28 19:26:39:584493] pilight-daemon: INFO: version v7.0
[Apr 28 19:26:39:688755] pilight-daemon: INFO: no pilight daemon found, daemonizing
[Apr 28 19:26:39:689108] pilight-daemon: INFO: daemon listening to port: 5000
[Apr 28 19:26:39:691128] pilight-daemon: ERROR: hardware not supported
[Apr 28 19:26:39:692609] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 34582
[Apr 28 19:26:39:692932] pilight-daemon: ERROR: could not initialize 433gpio hardware module

My hardware is still the same.

Can anybody help, I really need pilight to work. Any help would be really appreciated.

Hi @SmartValley, had the same problem on a pi without HA.
I assume you made a ‘rpi-update’?
The only way for me was to downgrade the kernel with rpi-update.
https://tech.enekochan.com/en/2014/03/08/upgradedowngrade-to-a-specific-firmware-kernel-version-with-rpi-update-in-raspbian/

Edit: Installed the last 4.4 kernel, so
rpi-update 52241088c1da59a359110d39c1875cda56496764
But that’s your choice.

1 Like

You installed

rpi-update 52241088c1da59a359110d39c1875cda56496764

and it’s working for you now?

Yes, this worked for me.
But if you want you can search about the issue with pilight and newer kernels.
I think it needs an update, but i was to lazy for this.

2 Likes

Ok, I will try it and report back :slight_smile:

You are a legend!!! It works!!! I really appreciate it! :grinning:

Thx that worked for me 2