Ping device tracker stops in the middle of the night

I know the ping device track isn’t the best solution, but the only option for me right now.

After configuring it, it worked great for a couple of weeks. Then it suddenly stopped in the middle of the night, and both our devices went ‘away’. After rebooting it worked again.

Two days later, it suddenly broke again in the middle of the night.

anyone has an idea?

I’d switch over to the nmap device tracker. MUCH more reliable than ping.

What did you reboot to get it working again? Your HA instance or your device?

I will look into that, but i don’t want all devices discovered, so nmap with two specific IP’s instead of a network should be the best option?

I did a reboot from here, i quess that is rebooting the device:


Correct. This is how mine is setup. Since you’re on, you could leave off the scan_options (I think?). I only care about 3 IPs, so I use the range 200-202.

  - platform: nmap_tracker
    scan_options: " --privileged -sP "

Yeah, that’s a reboot of HA. Are you connected via WiFi or ethernet? I’m wondering if maybe the port is timing out or the interface from HA to the network. is running on a Rpi with ethernet connection. You would say that in case of a timeout or something, he should pick it up again automatically… but it doesn’t.

I will try NMAP later, and see how it goes. Thanks!

Configured NMAP last evening. Worked immediately, but…

This morning i found out that my GFs Samsung S9 went home > away > home every 5 minutes… what triggered my coming home automation every 5 minutes :expressionless:

Hmmm, I’d look at her WiFi settings and make sure that it’s not turning off the radio. Android has an annoying “feature” that will wake up the WiFi radio for short periods when the device is sleeping.

At a minimum, I’d turn off “WiFi power saving mode” and “Turn on WiFi Automatically”.