Pioneer receiver VSX 933 control


I have a Pioneer VSX 933 and I am trying to add it in Home Assistant.
I used to use Domoticz only, but I want to switch to Home Assistant so I have now one Raspberry Pi with domoticz running and one with Home Assistant.
In Domoticz I was able to control it using the onkyo-eiscp commands.
In Home Assistant I tried to control it using the Pioneer and Onkyo add-ons, but no luck (yet, hopefully).
These are the errors I get:

2020-02-11 09:02:44 WARNING (SyncWorker_19) [] Pioneer receiver refused connection
2020-02-11 09:02:44 ERROR (SyncWorker_11) [homeassistant.components.onkyo.media_player] Unable to connect to receiver at

For the Pioneer add on I tried ports 23, 8102 and 60128. All throw the same error.

How can I get it to work?

Does anybody know how I can get this working?


i use the onkyo integration for my VSX1131 using the below

  - platform: onkyo
    name: receiver
    receiver_max_volume: 164
      Blueray: 'Fire TV'
      Video 2: 'PS4'
      Video 3: 'PC'
      network: 'spotify'

More info for setting volume and inputs on

I changed media_players to media_player and added this to the configuration:

  - platform: onkyo
    name: receiver

This is what returns in the log:

Unable to connect to receiver at
14:24 components/onkyo/ (ERROR)

So it doesn’t work… Do you know why this is the problem?

is .234 your receiver and .200 your HA?

with your receiver on does the eiscp give you if you run this

onkyo --host source=query

The official component had issues with my model and now Im using this custom component and is working great!

  - platform: pioneer_vsx529
    port: 8102
    name: Pioneer VSX-822
      'DVD': '04' 
      'TV': '05'
      'SAT/CBL': '06'
      'BR': '15'
      'VIDEO': '10'     
      'BD': '25'
      'Webradio': '38'
      'PANDORA': '41'

Do I need to SSH access to the host to do this or can I do this with the SSH add-on?

It needs to be run in the instance so that depends on your install. it will either be ssh or if you have it running within docker you can possibly access console.

I am using hassio. I have followed this: and I have SSH access via the SSH add-on and also access to the host as explained on that page.
I logged in with “login” on the host and tried this:

ha > login
# onkyo
/bin/ash: onkyo: not found

However, it doesn’t find onkyo.

And this is in my configuration:

  - platform: onkyo
    name: receiver

Does someone know why it isn’t working? Shouldn’t the onkyo commands be available?

Have you tried

That doesn’t work for me.

Does anyone know what intergration i need for the VSX 828 (2014)
I used the the Pioneer intergration but cant seem to send any media to it using Home Assistant media
and i can seem to controll the volume but it doesn’t show on the Pioneer display

Thanks this works perfect for my VSX-828