Pioneer Receivers - HTTP Requests

I’ve never been able to control either of my Pioneer AVR’s with the Pioneer Component, I could only view their status.

Searching for other ways to control it I stumbled across this page:
http://www.vrdigitalworld.com/audio/controler-son-ampli-home-cinema-pioneer-par-requete-http?lang=en

Following the instructions I’m able to control my AVR via the REST API in Node-Red
Thought it might be helpful to others who have the same problem I did.

1 Like

Did you try the Onkyo component?

I did, it didn’t function at all with the Onkyo component.

Which model?

I’ve just managed to update the Pioneer component to work with my Pioneer VSX-920, which had a similar issue (could get info, but not send commands). It turns out the protocol over IP/telnet requires a few carriage returns to be sent to wake up the CPU… so the first command sent over a new connection was always returning an error.

I will look at submitting a pull request with the change, so that the main pioneer component gets updated.

Protocol details were here: https://www.pioneerelectronics.com/StaticFiles/PUSA/Files/Home%20Custom%20Install/VSX-1120-K-RS232.PDF

1 Like

I have two, VSX-1325 / VSX-1125. The 1325 is the big brother to the 1125 from the same year. So I’m not surprised they are both have the same problem.

What changes did you make to the component to get it working? I’ve got a vsx-1325 and would love to get it working in HA.

Can you tell the changes you made in details i have same VSX-920 and cannot make it work.

I’ve now put my modified custom component on github:

I will try and do a pull request to add the fix to the official component, but in the mean time you can try this. Let me know if it fixes your issue and your VSX model number, so I can update the documentation of affected models.

I gave it a go, I now have control over everything except the source. The only option I have to select is Internet Radio. It will report the correct source in the Attributes if I change it manually.

Hi Snowboardy, I have a VSX-2021. Now I am able to switch it On. Thats great. Thanks!
When source selection is set to true, it shows only HDMI 1 and BD. So I am missing quite a list of sources here. Is your code reading this from the receiver or do you need a list of sources so you can change the sources for this model? I should I just use source selection->false?

I added code to only show sources that are enabled (not skipped) on the receiver. You can disable that by setting enabled_sources_only: false in the yaml. The github readme file explains fully.

You can also specify the list of sources, the same as the standard HA pioneer component.

1 Like

Hi Snowboardy, not sure if I implemented it correctly, but my config looks like this now:
media_player:

  • platform: pioneervsx
    name: “VSX2021”
    host: 192.168.1.66
    port: 23
    enabled_sources_only: false
    sources:
    ‘TUNER’: ‘02’
    ‘CD’: ‘01’
    ‘Adapter port’: ‘03’
    ‘DVD’: ‘04’
    ‘TV/SAT’: ‘05’
    ‘VIDEO 1(VIDEO)’: ‘10’
    ‘DVR/BDR’: ‘15’
    ‘iPod/USB’: ‘17’
    ‘HDMI1’: ‘19’
    ‘HDMI2’: ‘20’
    ‘HDMI3’: ‘21’
    ‘BD’: ‘25’
    ‘HOME MEDIA GALLERY(Internet Radio)’: ‘26’

But this results in a bad config: sources is not supported by “pioneersvx”. Should i just skip the sources?

Ah, sorry, my bad! … I should have checked the code before answering. The code used in my component was taken some time ago and the sources list was added since.

Yes, remove the sources:, and it will load all of the sources available.

If there are any sources that you do not want available, you can disable them using:

disabled_sources:
- TUNER
- DVD

I’ll try and find some time this week to make a pull request for this wakeup fix to the official component, as I don’t really want to support a separate fork of the component based on old code.