Pip3 fails to find newer version of homeassistant core

I’m attempting to upgrade homeassistant but I’m quite confused by this result -

(homeassistant) [email protected]:/home/pi $ pip3 install --upgrade homeassistant
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: homeassistant in /srv/homeassistant/lib/python3.7/site-packages (2021.1.5)

Seems like its finding the current version and declaring it the latest even though 2021.8.8 is out.

Anyway, any suggestions would be much appreciated. My googling has failed to turn up anything useful.

aaand I suspect that I need to be running python 3.8

RTFM?

from Linux - Home Assistant

Thats mentioned nowhere in the upgrade instructions!

That was mentioned back in Release 2021,2 When skipping versions you are expected to read all the intervening Release Notes!!

Python 3.7 dropped, Python 3.9 supported

Support for Python 3.7 has been removed, raising the minimum Python version you need to run Home Assistant Core to Python 3.8. Python 3.7 was already deprecated since Home Assistant Core 0.116.0.

This is only a concern if you are running Home Assistant Core directly on Python. If you run Home Assistant OS, Supervised or Container, you don’t have to worry about this, as the Home Assistant project takes care of this for you.

However, say hello to: Python 3.9. As of this release, Python 3.9 is fully supported and tested

from 2021.2: Z-Wave... JS! - Home Assistant

When skipping versions you are expected to read all the intervening Release Notes!!

Homework is lame!

I have HA working with 3.8.

Now I’m trying to go to python 3.9 and I get this in the homeassistant log -
Unable to load auth provider homeassistant: libffi.so.7: cannot open shared object file: No such file or directory

Any suggestions?

I’m getting a similar error:

Component netatmo libffi.so.7: cannot open shared object file: No such file or directory

Looks like I will have to find a workaround

@Codec303 Either you can link libffi.so.7 to libffi.so.6 . Looks like Raspberry Pi OS will be updated in the next couple of months and such hacks won’t be needed anymore. I’m just going to wait.

1 Like

Thanks, I’ll back to a Python 3.8 based install for now, thanks for the info

Any news on this topic? Home Assistant complained today to me that I have to update to Python 3.9 until the release 2022.1 but I still cannot use Python 3.9 because of the mentioned error…

I found a solution on how to manually install libffi.so.7 on Raspberry => Python install on Raspberry PI OS - #12 by torkis