Playing internet radio via Sonos

Trying Sonos Roam with HA like this:

service: media_player.play_media
  entity_id: media_player.sonos_roam
  media_content_type: playlist
  media_content_id: >-

that works.
But ‘’ (or ‘…/mp3’) does not. The speaker does not barf but does not play either. What is broken here?

Played a bit with settings and TVH and talked to Sonos community. So, these 3 work fine with the Sonos app and TuneIn:
http://tvh:9981/stream/channel/7107b2b55e2338100e9cf1be33411cdf (local TVH)

Tried like this (the same in webui):
hass-cli -s http://hass:8123 --token xxxx -x service call media_player.play_media --arguments entity_id=media_player.sonos_roam,media_content_type=music,media_content_id=

I tried all sorts of media_content_type, but HA’s Sonos only plays “bbc_6music”. What is missing?

freaking weird :slight_smile: This works:

hass-cli -s http://hass:8123 --token xxxxx -x service call media_player.play_media --arguments media_content_type=music,entity_id=media_player.sonos1,media_content_id="aac://http://tvh:9981/stream/channel/9ce444d48e0008460df9ae9bd27a4f03"

So it has to have aac://http:// , http:// is not enough.