Playstation 4/PS4 custom component

media_player
Tags: #<Tag:0x00007f47ff1333c0>

#123

The component I modified was created by vkorn to support his hass.io (= docker) add-on, which uses a REST wrapper around ps4-waker. So you should only use this custom component if you’re running a docker container with the REST wrapper (either vkorn’s hass.io addon or you can use one of my images.

@glassbase could you post your logs please?

@Bieniu my config uses the ip with protocol for the host incl. port and the plain ip for the PS4. So it looks like this:
host: http://0.0.0.0:3031 ### IP of the docker container and port of the ps4-waker REST wrapper
ps4_ip: 0.0.0.1 ### My PS4’s IP

Hope this helps!


#124

I am having issues since .64 also.

I can still use ps4-waker commands in terminal and get the correct results. However my media_player.ps4 is not showing in states. The most I can achieve now is a popup that says

Playstation 4

Enter credentials

Howto generate credentials

(Line for credentials populated with “PS4 Waker credentials json”)

I have tried moving my credentials around into different folders always the same result. I have entered paths, user credentials, the full text from the json all result the same way.

Any ideas?


#125

You have to paste the the user-credential into the “Enter your credentials” popup.

{"client-type":"a","auth-type":"C","user-credential":"COPY_THIS_PART_HERE_INTO_PS4_CONFIGURATOR"}

In my case it unfortunately doesn’t help. The component doen’t react to changes in the PS4 status. Anyone have working version of this component for HA 0.64.x (virtualenv instalation)?


#126

Tried it. Didn’t work. Also using a Venv


#127

@Knapoc I will switch to using your rest wrapper docker and see if I can get it working. (I had it working with this docker). Will report back later tonight. Thanks


#128

There seems to be some confusion:

  1. This ps4 component is suitable if you’re using ps4-waker. Typical use-case: ps4-waker and home assistant run on the same host. E.g The docker image @glassbase just mentioned and regular installs like hassbian venv ect… For the full documentation check this wiki. This would be suitable for you @TehRobot1 & @Bieniu.

  2. The component component I posted depends on ps4-hass-waker by @vkorn (a REST wrapper around ps4-waker). A typical use-case would be if ps4-hass-waker and hass run on different hosts. ps4-hass-waker is available within vkorn’s hass.io repository or within my docker image (you can build it yourself though). Why is ps4-hass-waker (REST wrapper) even necessary? ps4-waker has an API, but doesn’t expose its service to the network (if I understood that correctly?!). Since docker best-practice is to run one application per container, I chose to build my own docker image with ps4-hass-waker only and didn’t just use the image hnicolaisen/home-assistant (@glassbase be sure that you still run a “pure” home-assistant container and check out the readme of my image on how I generated the ps4-config.json).

Hope I could help you somehow, even though I’m not an expert :slight_smile:.


#129

I don’t know what I did wrong yesterday. Today I downloaded the component from github again and it works.


#130

Seems to have worked for me also. I was just copying the code and updating the ps4.py file.

But a download and replacement of the file seems to have done the trick. It is actually recognising the credentials now when I enter them.

:smile:


#131

I am working on moving the module to python so it can be added to the official release, and I did some work on it to fix installation.

So it should start, but some features might not work in all setups yet


#132

first of all, I have to say thank you very much. your playstation4 custom component works very well and very good.
It is a little bit hard to install because need ps4 walker and some other setting involved. If move to official release, I hope it will not hard to install.
As now, it is still works well on HA 0.64.1


#133

Hi all
Can this be installed on hassio?


#134

#135

I’ve upgraded to HA 0.64.3 (Hassbian), replaced ps4.py with latest version and followed every instruction in the thread that I could find. But the the commands still do nothing, I only get the PS4 state, like what’s playing.
Here is an error log for media_player.turn_off command.
And media_player.media_play_pause error log.


#136

there are some problems inside docker to get the network packets to work, so right now only lookup works in hass.io


#137

In case this is a reply to my post, I’m not using docker, it’s a dedicated RPi3.


#138

thats strange, could you try running the command from the command line then?

would look something like this :
python3 /usr/local/bin/ps4-ctrl -v -H 10.254.2.107 -C 903a0d538cd5029172d15d0d711d7bb0f4e09974779a22c351b0f6c125fca498 wakeup

that should wakeup the ps4 (at least it does locally when I test it)


#139

First I got:
python3: can't open file '/usr/local/bin/ps4-ctrl': [Errno 2] No such file or directory

I checked /usr/local/bin/ and there was only a symlink for ps4-waker, I used that in CLI and got:

File "/usr/local/bin/ps4-waker", line 3
    var {Detector, Device, Socket} = require('../')
        ^
SyntaxError: invalid syntax

That looks like ES6 incompatibility, but my node is v9.5.0 and I can use sudo ps4-waker to wake up PS4 from CLI.


#140

the ps4-ctrl is python only code so now ps4-waker or node is configured does not matter.

I don’t know where it’s installed on your machine

try locating it with find / -name ps4-ctrl and then run the command I mentioned previously


#141

Ok, found it at /srv/homeassistant/bin/ps4-ctrl. Results:
https://hastebin.com/babarukula.sql

Edit: I tried pip3 install pyps4 but it changed nothing.


#142

the pypi module is not up2date so you can’t use that one

the easiest way to use the tool outside hass is to tell python where the modules are with the PYTHONPATH var could look something like :

PYTHONPATH=/usr/lib/python3.6/site-packages:/config/deps/lib/python3.6/site-packages

I don’t know the paths on your setup so you will have to locate those

but it’s likely that it’s something like this

PYTHONPATH=/usr/lib/python3/dist-packages:/srv/homeassistant/deps/lib/python3.6/site-packages