PlayStation 5 Command Line Sensor Help - Command Failed/Empty JSON

Ah yea thats probably my issue as I’m in New Zealand, whats the issue? Was there a workaround?

Yes I made this change also but still the same thing…

I just yesterday moved to HA Supervised and I’m not super familiar with all the quirks of using docker containers just yet, I’m assuming that’s where the ssh command comes in to execute this from container, but I’m having trouble figuring out where/how you did the ssh keygen…is that config/.ssh folder one you just created inside the Hassio dir or is that somewhere else?


At least on my system, that location is actually mounted to the docker host, so I access it via myuser@pi:~/homeassistant (this can be configured individually). The docker container should have a volume set up that associates that location in the container with one elsewhere. Otherwise, you can log into the container and run it from there (not sure how to do this myself, I tend to just use Portainer to access it this way if I need to).

I tried to run the binary from that same mounted volume but it just wouldn’t go… I assume some security setting on the docker image.

Thank you, I was able to find the directory listed in Portainer, then I was able to find this post: Hassio in Docker - SSH Key - Host key verification failed - KVM Integration which guided me in generating the key. All good now. Thanks for your help.

Thank you for the guide, these are the kind of posts I always appreciate!

I am running into an issue. I have Home Assistant 2021.1.5 running on a Raspberry Pi 4 using the IMG from the website. I’ve clicked the Terminal option in the left side navigation within HA and cloned the ps5-wake repo and entered that directory. However HA does not recognize sudo or make. Why is that?

Because you’re using hassos and I use rpi os. It’s a spare rpi I have for various stuff.

would this work with the PS4 too? (obviously using ps4_wake instead

I guess so, but why not just use the ps4 integration?

i already have that in place, but only media_player entity gets created, no sensors… how would you create the same sensor?

i’m particular interested in having a sensor and a switch exactly like your so that i can use it in your fantastic dashboard

Nothing for hassio users yet? With the PS4, I had an automation running to switch the HDMI input on my TV after the console switched off, since it didn’t have the option to disable the TV HDMI-CEC switching on the PS4 (like how the XSX does). Same problem with the PS5, if the TV is switched off on HDMI-1 (PS5) and the wife switches on the TV, it switches on the PS5 as well.

Going to try and use the ‘No Signal’ state on the TV to try out an automation while I wait for something on hassio

There are a few examples above that make sensors to tell you the state… you can just use those to turn on the PS as needed if the input changes? I’m not sure I understand what you are looking for.

Looking to install the ps5-wake on an r-pi running hassio/hassos. I don’t have ssh access to the system.

Alternative is using the ping sensor, this works for me. Mind that standby is also reported as active (in my PS5 configuration, yours might be different due to automatic update settings etc.)
I use this perform TV and amplifier input changing and to remind my son every half hour of his play-time :D.
Of course an integration replacing the PS4 one would be nice

first of all thanks for sharing this ps5-wake integration. I’m completely new to this HomeAssistant and coding stuff, and I’ve got problems with the installation process. When I type “make install” an error occurs.
That is the output:

➜  ps5-wake git:(master) ✗ make install
gcc -O2 -g -pipe -Wall -std=gnu99 ps5-wake.c sha1.c -o ps5-wake
make: gcc: Command not found
make: *** [Makefile:7: all] Error 127

I hope you can help me.

You need to install the tools before you can use them.

apt-get install build-essential

Thanks a lot. I guess it works now. But now I have to look for the user-credentials.

Hm now there is the next problem:
When I try to execute these commands then I just get the following output:
The start via the PS Remote Play works fine.