Please can somebody fix the Hive component. It's a simple fix

Please can somebody fix the Hive component. It’s been broken for 3 releases, although the fix is very simple, identified and in the forums here. Here’s the discussion

Basically it needs somebody to update the line

HIVE_API.urls.global_login = ""


HIVE_API.urls.global_login = ""

in the pyhiveapi file.

Actually looking into it - it appears that HA is using an outdated version of Pyhiveapi - the latest version on Github would appear to be correct.

Many Thanks,


It looks like a fix was merged into 0.116.1, what version are you on?

.117.6 and it wasn’t fixed then. I had to manually edit the file myself. Using the docker image BTW.

I just upgrade to the latest “homeassistant/home-assistant” docker image - reporting as version 0.118.2.

Still the same issue. Had to go into the terminal, open up bash in docker and manual amend the file


which was incorrect and still had

HIVE_API.urls.global_login = ""


HIVE_API.urls.global_login = ""

This is completely not fixed.

Sounds like a perfect opportunity to report the issue on github so it can get fixed :wink:

Just looked at mine and it’s cognito not global, on 0.118.2 (also docker)

Therefore correct according to that.

Thanks for checking. Had a further root around. Turned out at some point I have installed the HACS Hive custom component. Removed that, nuked the container and tried again - working fine. User problem as ever.

1 Like

Glad to hear it’s sorted, as I have a similar setup I hoped it would be useful, didn’t think about the custom component!

1 Like