Please help! Can't remove hassio_supervisor & rest of containers

I have read 100 topics on this with no usable solutions. I am running HA in docker on a Synology DS1019+. I wanted to start from scratch, remove all services and rebuild. Unfortunately hassio_supervisor restarts right away after I stop it and I can’t delete it.

  • I’ve tried it from the Synology/docker UI.
  • If I run docker kill <container_id> a new process starts right away som I can’t run docker rm <container_id>
  • I tried docker update --restart=no <container_id> and it doesn’t error out but the container still restarts

The only thing I haven’t been able to try is to run sudo systemctl stop hassio-supervisor.service because it get sudo:systemctl: command not found and I don’t know what to do about it

If I go into HA and I navigate to Settings > System > Hardware> 3dots > Shutdown system I get " No HostFeature.SHUTDOWN D-Bus connection available "

But since I’ve been messing with it, HA gives me now a notification of " Unhealthy system - Docker misconfigured"

So what should I do to kill the supervisor container and other 7 hassio containers that are also being restarted by the supervisor so I can start fresh. I don’t want to wipe out the Docker service on the synology because I’m running other containers that I don’t want to have to rebuild.

Thank you so much!!!

edit: running DSM 6.2 on the 1019+

It appeas that systemctl was replaced with synoservicectl after DSM 6.1 and when I run:

sudo synoservicectl --stop hassio-supervisor.service

as per Uninstall hassio , I get hassio.supervisor.service failed to stop…error unknown [0x400 servicectl_status.c:27]. Has anyone dealt with any of this? It’s getting ridiculous and I’m about to buy a darn Hubitat C7

You can use “docker rm -f” to force removal of a running container.