Please help.. Installation error installing HA on Windows10 + Python 3.7.7

When I run the below command on Windows 10 (after installing the latest Python version 3.7.7) I can’t get passed the installation error below. It looks like it’s a Python-related error

Things i’ve tried (everything bu tthe kitchen sink):

-Upgrading to the latest Python version 3.7.7
-Deleted the config directory for HA and reinstalled HA
-Installed “Build Tools for Visual Studio”
-Upgraded PIP to the latest version
-pip3 install homeassistant --no-cache-dir
-pip3 uninstall wheel …pip3 install wheel
-pip install pip --upgrade
-pip install setuptools --upgrade

pip3 install homeassistant

The installation starts output red text error message; and, halts the installation:

Installing collected packages: ciso8601, homeassistant
    Running install for ciso8601 ... error
    ERROR: Command errored out with exit status 1:
     command: 'c:\users\michael\appdata\local\programs\python\python37\python.exe' -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\Michael\\AppData\\Local\\Temp\\pip-install-mo203h2c\\ciso8601\\'"'"'; __file__='"'"'C:\\Users\\Michael\\AppData\\Local\\Temp\\pip-install-mo203h2c\\ciso8601\\'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\Michael\AppData\Local\Temp\pip-record-5_mq23wj\install-record.txt' --single-version-externally-managed --compile --install-headers 'c:\users\michael\appdata\local\programs\python\python37\Include\ciso8601'
         cwd: C:\Users\Michael\AppData\Local\Temp\pip-install-mo203h2c\ciso8601\
    Complete output (12 lines):
    running install
    running build
    running build_py
    package init file 'ciso8601\' not found (or not a regular file)
    creating build
    creating build\
    creating build\\ciso8601
    copying ciso8601\__init__.pyi -> build\\ciso8601
    copying ciso8601\py.typed -> build\\ciso8601
    running build_ext
    building 'ciso8601' extension
    error: Microsoft Visual C++ 14.0 is required. Get it with "Build Tools for Visual Studio":
ERROR: Command errored out with exit status 1: 'c:\users\michael\appdata\local\programs\python\python37\python.exe' -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\Michael\\AppData\\Local\\Temp\\pip-install-mo203h2c\\ciso8601\\'"'"'; __file__='"'"'C:\\Users\\Michael\\AppData\\Local\\Temp\\pip-install-mo203h2c\\ciso8601\\'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\Michael\AppData\Local\Temp\pip-record-5_mq23wj\install-record.txt' --single-version-externally-managed --compile --install-headers 'c:\users\michael\appdata\local\programs\python\python37\Include\ciso8601' Check the logs for full command output.

I would really appreciate any help to get this past these error messages. I dont have any other issues related to Python on mysetup.

I have the same problem since version 107.
Uninstall previous versions of visual c ++ and try to install versions 2019. In no case did it work

The solution offered here solved it for me.

I just follow the same tutorial and it works

Maybe I’m doing something wrong, Did I install the right options (see below)? I installed those options below and rebooted. It did not resolve the issue for me.


Did you find a solution? I’m having the same issue.

These settings seems to work for me: