Please help with accessing HA files on Ubuntu Virtual Machine

Hi all

I have installed HA on Ubuntu VM and cannot access its files directly from Windows or on the Ubuntu Server itself. I have tried many things eg. SAMBA addon on HA, etc. I want to copy media files to the Media directory. Can someone please assist? I’m a complete novice when it comes to VMs.

Thank you in advance

Installed how? HAOS I assume if you used a VM?

If you have HAOS installed, install the File Editor and Samba Share add-ons.

EDIT: I maybe assume wrong. If you are using Ubuntu VM on Windows the only supported method is Docker container…

Ok - missed that you installed Samba. This is the list of shares Samba presents:

Screenshot 2023-07-20 at 20.10.55

In Samba Share config, check Veto Files and Allowed Hosts lists and that any user/workgroup settings are correct.

Hi Daryl

Thanks. I am aware of the shares, but my VM is in another subnet eg ( on my Ubuntu which is on and my Windows Explorer does not show HOMEASSISTANT under Networks. I can only access the SAMBA Server of Ubuntu on IE. My Windows PC is on Although I can access HA on

How do I get access to/from my VM?

My host machine is my HAOS VM (virtualbox) on ubuntu is I have the following add-ons loaded into HA.

Samba, lob viewer and terminal & ssh are the important ones for this.

I have fstab on the host set up like this.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/ was on /dev/sda5 during installation

UUID=0dcc0b32-5efe-4591-a818-80732d6de3a9 / ext4 errors=remount-ro 0 1

/boot/efi was on /dev/sda1 during installation

UUID=F917-C78F /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0
// /home/jonny/haconfig cifs uid=0,credentials=/home/jonny/.haconfig,iocharset=utf8,vers=3.0,noperm,comment=systemd.automount 0 0

Home Assistant share directory

// /home/jonny/share cifs uid=0,credentials=/home/jonny/.haconfig,iocharset=utf8,vers=3.0,noperm,comment=systemd.automount 0 0

Home Assistant backup directory

#// /home/jonny/backup cifs uid=0,credentials=/home/jonny/.haconfig,iocharset=utf8,vers=3.0,noperm 0 0

I run mount -a after the VM is up and running and it makes all the samba shares.

Hope this helps you.

Thank you. So it seems I have to get my VM’s IP Address in the same subnet.

All of my sensors are on and All of my servers are on Everything in the host is on the same subnet. My edge router supplies all of the IP addresses. I have them fixed in the router. I also run pi-hole as the gatekeeper.

I agree with your conclusion.